Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

A custom background plugin has started to cause certain browsers (FF, IE8,9, Safari) to reveal an appended url string when viewing the index page: http://dearearth.net - this mostly shows when not visiting the site directly, but rather when going through, for example, google.

This persists in IE 9 even after refresh or page reload, but does not on the other browsers.

Screenshot: http://i55.tinypic.com/2nv9fh3.jpg

I have the following custom permalink structure enabled:/%category%/%postname%/

Thanks for any input!

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

This doesn't have to be a plugin issue.

If someone puts a link on their website to your blog say for example: www.example.com but not only that they place some random string: www.example.com/?foo=bar in that link to your site then when search engines crawl this page with the link to your site on google or any other search engine will see it and try to follow the link to your website.

As is the URL is technically valid the search engine will cache it and serve this new URL to its users.

Have a read over this post at Perishable Press that talks about it in detail.

http://perishablepress.com/clean-up-links-htaccess/

share|improve this answer
    
@Brady However, this happens to be a plugin issue! If you go directly to the site through IE9, the string appears. When the plugin is disabled.. surprise... the string ceases to appear. –  vulgarbulgar May 6 '11 at 11:04
    
@vulgarbulgar no the string appears for me in any browser... what plugin is causing this? –  Brady May 6 '11 at 11:17
    
@vulgarbulgar it seems to appear if I'm being referred from a website that it appears. So if I click the link from this site the url changes. But if I type it in manually I dont get the code. –  Brady May 6 '11 at 11:22
    
@Brady This plugin: codecanyon.net/item/custom-backgrounds-for-wordpress/121983 –  vulgarbulgar May 6 '11 at 11:34
    
@Brady As someone suggested, I did reset the permalink settings, several times, to no avail. –  vulgarbulgar May 6 '11 at 11:35
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.