Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I want to create a static, company brochure site. I created a page called "HOME" and I was able to change the reading settings to static, and select "HOME" from the drop down box. I then created a page named "ABOUT-US". It appears in the main menu, but when I click on it I get a 404 error. I also need to create an page called "ADVANTAGES", with sub pages (e.g. Advantage-A, Advantage-B, etc.). How can I do this?

I am new to WP. I've tried blogging and its fine. Can anyone suggest a tutorial or book for this? It would be a great help. I Googled it in vain, it was no big help.

share|improve this question

1 Answer 1

First, check your permalink settings: Dashboard -> Settings -> Permalinks

Second, check to ensure you don't somehow have a Page slug conflict. Go to Dashboard -> Pages, click the "Trash" tab, and ensure you don't have any Pages in the trash (if so, delete them if you don't need them).

Third, check the page-slug for your "About-Us" Page, and ensure that it matches what is being linked in your Page Menu. If they don't match, that will explain your 404 error.

share|improve this answer
    
1.Permalink : I have created .htaccess in the main directory but when i try to create a new custom structure :/advantages,i get "You should update your .htaccess now." –  kracekumar May 3 '11 at 17:59
    
2.I dont have any file in trash. –  kracekumar May 3 '11 at 18:01
    
3.I don't have any slug named "About-us".,i have link named advantages. . . –  kracekumar May 3 '11 at 18:02
    
@kracekumar 1. Sounds like your .htaccess file is not writable by your webserver. You'll want to update the permissions on the file so the webserver can write to it and then retry setting your permlink structure. –  Manzabar May 3 '11 at 18:05
    
@Manzabar:.htaccess file has permission 755 –  kracekumar May 3 '11 at 18:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.