Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I just installed WordPress 3.1.2, I got

`Notice: automatic_feed_links is deprecated since version 3.0! Use add_theme_support( 'automatic-feed-links' ) instead. in /works/web/elements/wp-includes/functions.php on line 3303

I also got an error about Cannot open stream or something about wp-cron.php?doing-cron or something

Its WordPress's own code, plus from a fresh install, this should not happen right?

UPDATE

The error I got was

Warning: fopen(http://elements/wp-cron.php?doing_wp_cron): failed to open stream: HTTP request failed! in /works/web/elements/wp-includes/class-http.php on line 1063

Running WordPress 3.1.2 fresh install

share|improve this question

3 Answers 3

up vote 4 down vote accepted

it sounds like even though its a fresh install of WP 3.1.2 that you are also using an existing theme that is using a deprecated function (you havent said so but im presuming),

if so paste this into your themes functions.php file (if your theme doesnt have one just create one and save it in your themes root folder)..

if(function_exists('add_theme_support')) {
add_theme_support('automatic-feed-links');
}
share|improve this answer
    
It's your Theme. The error message should be self-explanatory. Remove the automatic_feed_links() function from functions.php, and replace it with @Martin's code above. –  Chip Bennett May 2 '11 at 12:23

I fixed the wp_cron error by editing php.ini in my php installation. Make sure you have allow_url_fopen = On and allow_url_include = On

share|improve this answer
    
Nothing in WordPress should neither of those to be set to true, and enabling these PHP config options can introduce potential security vulnerabilities. If you're using a Theme that requires either/both of these to be enabled, then I would suggest modifying the Theme, or finding a better Theme. –  Chip Bennett Jun 26 '11 at 3:13

In addition to Martin's answer: the ?doing-cron error message is probably due to having ALTERNATE_CRON set to true in wp-config.php.

share|improve this answer
    
It can also be the cache enabled in a local install... –  kaiser May 2 '11 at 13:11
    
I dont see a ALTERNATE_CRON in my wp-config.php tho... –  Jiew Meng May 7 '11 at 0:42
    
@kaiser, meaning this should only happen on localhost isit? But what cache are you talking about and how can I enable/disable it? –  Jiew Meng May 7 '11 at 0:44
    
I updated my post with the error message in case u find it useful ... –  Jiew Meng May 7 '11 at 12:13
    
Not absolut sure, but maybe: define( 'WP_CACHE', true ); or define( 'ENABLE_CACHE', true );. I wrote "localhost", because i get this error from time to time, but only on my local install. –  kaiser May 7 '11 at 17:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.