Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.
  • I've installed Easy Post Types
  • created a custom post type: Attractions
  • created an Attraction: (joes-cafe)
  • created a category set: attraction-type (cafe)
  • copied single.php to single-attractions.php
  • added the category: cafe to wp-navigation-menu

But when I visit the menu item, I get a 404, when i search for the cafe by name, i see an excerpt, but clicking its title gives me a 404!

Any Clues? What am i doing wrong?

I am using a Thematic child theme, and i duplicated single-attractions.php as single-attraction.php just in case, because i found the distinction confusing...

Thanks, Tim

share|improve this question
    
My apologies, people - everything seems to be working now, though I have no idea what I changed! –  memeLab Apr 29 '11 at 19:13
2  
The rewrite rules need to be flushed when you add a custom post type, this can be done by visiting the permalinks admin page. –  Milo Apr 29 '11 at 19:21
    
ah! that makes sense, thanks! –  memeLab May 4 '11 at 3:34
    
@Milo: Can you copy that comment in an answer? Then we can vote on it and get this question off the "unanswered" list. –  Jan Fabry May 4 '11 at 21:00
    
You can click the checkbox next to Milo's answer to mark it as the one that helped you. I would upvote it, but I spent all my votes for the day. –  Jan Fabry May 4 '11 at 21:08

1 Answer 1

up vote 1 down vote accepted

The rewrite rules need to be flushed when you add a custom post type, this can be done by visiting the permalinks admin page.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.