Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a problem when i want to upgrade Wordpress or install plugin via the Admin.

It's say that I don't have the permission to write. but I can upload images and other things... but i cannot install plugin and/or update plugin/WordPress.

I know that my user server is not the file owner but is part of the group owner.

share|improve this question
    
define('FS_METHOD', 'direct'); core.trac.wordpress.org/ticket/10205 –  Eduplessis Apr 29 '11 at 16:29

2 Answers 2

up vote 0 down vote accepted

I find the answer to my question

define('FS_METHOD', 'direct');

core.trac.wordpress.org/ticket/10205

thanks @xLRDxREVENGEx for the tip for upgrading manually but when you make a theme framework and you want to update you parent theme framework in the admin you need to apply the

define('FS_METHOD', 'direct');
share|improve this answer

I have had the same issue and it is do to how apache and wordpress communicate. It has to have both owner and group permission to install from backend. The only really way to get around this is to see if your host has a server setup that way or you get your own server weather it be vpn, dedicated, or cloud. I personally to the challenge and used rackspace cloud server and setup my server with what i wanted on it and how it was programmed to run. It cost me about 12-13 a month but the speed is way better and the fact that you get root permission from the start is better and to top it off no other users on that virtual server. There are others on the system your server resides on but not 5000 people on one system like you can find on a shared environment.

One final tip do not use wordpress auto upgrade it is best to do it manually yes it is a pain but it insures that you wont have an issue and not be able to fix it check out this article From WPMU.ORG

share|improve this answer
    
that open trac ticket is from version 2.8 so since we are on version 3.1 now with wordpress and it still has not been fixed i doubt there is a simple fix to it and think that it is still caused by apache and wordpress communications. –  xLRDxREVENGEx Apr 29 '11 at 16:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.