Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I want to turn the post-excerpt function on but it doesn't even show as an option under 'screen options' for posts. How do I get it to display as a check box under screen options?

I have tried inserting the code...// Change what's hidden by default... into the function.php but this causes problems. Perhaps I am not inserting the code into the correct part of the file or something or have left something vital out?

share|improve this question
    
It should be there by default unless you've done something to remove it. –  Bainternet Apr 26 '11 at 0:06
    
Just set the site up last night and have done nothing apart from adding some plugins and content. –  Dee Apr 26 '11 at 0:17

1 Answer 1

Are you on the Edit Post Screen, or the Edit Page screen?

Pages do not support Excerpts by default, although you can enable it.

share|improve this answer
2  
yeah, that seems to be the only reason possible. To add exerpts for Pages, add the following line to your functions.php file: add_post_type_support( 'page', 'excerpt' ); –  Piet Apr 26 '11 at 1:12
    
I'm on the Edit Post Screen –  Dee Apr 26 '11 at 1:15
1  
Oh I have it sorted, I was looking at the screen options on the main posts page. I just click on an individual post then screen options and there it is the excerpt option. Sorry to waste your time, but thanks for your help. It is there by default. –  Dee Apr 26 '11 at 1:22
    
Glad it was something easy! :) –  Chip Bennett Apr 26 '11 at 2:10
    
@Dee please post your solution as an answer and accept it. –  Brady Feb 21 '12 at 15:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.