Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Okay guys, here's the scenario.

I'm am trying to setup a function that will automatically duplicate a post (when published) over to another post type. So, a regular blog post is published, and when it is published, all of its information is copied over to a custom post type (for WP ECommerce), automatically creating a store entry for that blog post.

I've written a function that takes care of picking up all of the information and inserting it into a new post with wp_insert_post(). It all works great, except for one thing. I'm using wp_set_object_terms() to set the store category ids of the new product based on the tags of the blog post. However, for some reason, wp_set_object_terms() never works.

Now, here's the catch. I'm running all of this on a multi site install and am using threeWP_Broadcast to allow me to cross publish posts. The blog posts (which have to be copied to the store) are published from a sub site and broadcasted to the main site. The store is on the main site.

So I've hooked my custom function into the broadcast plugin so that it gets fired when a post is broadcasted from a sub site to the main site.

Everything with my function works great, except for the wp_set_object_terms()

Here's function:

function copy_post_to_store_product() {

global $blog_id;
global $wpdb;

// only copy the post over if on main site, not subsites
if ($blog_id == 1) {

    $args = array('numberposts' => 1);
    $latest = get_posts($args);
    foreach($latest as $post) : setup_postdata($post);

        // if NOT Tip and NOT source avail, create product
        // if source, price is ALWAYS $4
        // auto create for source files only -- regular post type

        $custom_meta = get_post_custom($post->ID);

        // what kind of post is this?
        $post_type = $custom_meta['cgc_post_type'][0];
        // does this post have a source file product associated with it?
        $source_avail = $custom_meta['cgc_source_avail'][0];

        // source file price
        $price = '4';


        $product_info = array(
            'post_title'    => $post->post_title,
            'post_type'     => 'wpsc-product',
            'post_content'  => $post->post_content,
            'post_author'   => $post->post_author,
            'post_status'   => 'draft', 
        );


        if($post_type == 'Regular' && $source_avail == true) {
            // only auto create product for Regular posts that have source files for sale
            $product_id = wp_insert_post($product_info);
            update_post_meta($product_id, '_wpsc_price', $price);

            if (has_tag('blender', $post->ID)) 
            { 
                $product_cats = array(23,32);
            }
            elseif (has_tag('max', $post->ID)) {
                $product_cats = array(23,34);
            }
            elseif (has_tag('modo', $post->ID)) {
                $product_cats = array(23,19);
            }

            // set the product categories
            wp_set_object_terms($product_id, $product_cats, 'wpsc_product_category' );

        }


    endforeach;
}

}

The function works by retrieving the latest post from the main site ($blog_id == 1) and copying all of its information into variables for wp_insert_post().

Now, the really interesting thing is that works perfectly if I attach the function to a publish_post hook, but, unfortunately, I can't do that because that hook doesn't fire when a post is broadcasted.

Any ideas would be hugely appreciated.

share|improve this question
    
What does wp_set_object_terms() return for you? –  Rarst Apr 29 '11 at 9:40
    
Nothing at all, at least not than I can tell. It acts as though it worked, but nothing gets set. –  Pippin Apr 29 '11 at 18:19
    
@Pippin it should always return something (can be different things depending on if it worked and what error is if it didn't), wrap it in var_dump() –  Rarst Apr 29 '11 at 18:42
    
@Rarst this is what I'm getting: object(WP_Error)#1159 (2) { ["errors"]=> array(1) { ["invalid_taxonomy"]=> array(1) { [0]=> string(16) "Invalid Taxonomy" } } ["error_data"]=> array(0) { } } –  Pippin May 4 '11 at 14:19
    
@Rarst I know that the taxonomy name is correct, as well as the IDS, so I really don't understand that error. –  Pippin May 4 '11 at 14:20
show 1 more comment

4 Answers

up vote 0 down vote accepted

I don't have a solution, but here's the root of your problem: http://core.trac.wordpress.org/ticket/20541

Apparently a call to switch_to_blog() would not repopulate $wp_taxomies, which these taxonomies rely on.

share|improve this answer
    
Yep, I found that out recently as well. Thanks for posting the link. –  Pippin Oct 22 '12 at 14:23
add comment

Forget about the previous answer, You say that it works fine with publish_post hook then you create a plugin in your mu-plugins (“must-use” plugins) which you can hook your function to and just add switch_to_blog before you start inserting and updating things in the database and then revert back using restore_current_blog() So

switch_to_blog($main_blog_id); //usually 1
...
//your function
...
restore_current_blog();
share|improve this answer
    
Nope, didn't make any difference –  Pippin Apr 29 '11 at 18:22
    
Ok, i have another idea for you I'll post in a little while. –  Bainternet Apr 29 '11 at 19:45
    
@Pippin: I added a new solution. –  Bainternet Apr 29 '11 at 21:06
    
I know what you mean by mu-plugins and such, but I'm not sure I'm following how that fixes it . . . –  Pippin Apr 30 '11 at 4:59
    
its not fixing it its doing the same in another way and avoiding the use of threeWP_Broadcast all together, since you are using every blog's save_posts and hooking it to the same function which will work on the main blog. –  Bainternet Apr 30 '11 at 12:23
show 7 more comments

Just throwing this out there: I had a similar problem once where a taxonomy was not available at the time my function was running. This could either be a problem with wp ecommerce or the broadcast plugin.

Check if the wp ecommerce plugin uses this syntax for registering their taxonomy

add_action( 'init', 'taxonomy_function_name', 0 );

Check if they appended the ,0. This sets the priority of the taxonomy function to 0. Which would be as early as possible.

Is it possible to set priority for the broadcast hook?

share|improve this answer
    
WP eCommerce is using that format, but they have set a priority of 8. But I don't think this could have anything to do with it, could it? The plugin is active and functioning fine at the time I am trying to use wp_set_object_terms –  Pippin May 5 '11 at 19:40
    
It can if the broadcast plugin functions before the taxonomy exists, you will get the invalid taxonomy i think –  Patriek May 5 '11 at 19:53
    
I understand that. But the taxonomy exists once the plugin has been activated. The broadcast function only takes place after publishing a post, which only happens in this case after the plugin has been activated and in use for a while –  Pippin May 5 '11 at 20:17
    
depends at which hook the post intercept is called, you can try setting the tax to 0 see if it helps. –  Patriek May 5 '11 at 20:56
add comment

I just came across the same problem and worked out a solution with help from Patriek's answer. You just need to make sure that wp_set_object_terms() is run after the custom taxonomy is registered. Since register_taxonomy() is usually run at init, you can also run your function at init, but with a lower priority so it runs later.

add_action( 'init', 'register_custom_taxonomies', 0 );

function register_custom_taxonomies() {
    // register your taxonomies here    
}

add_action( 'init', 'copy_post_to_store_product', 10)

function copy_post_to_store_product() {
    // your function that runs wp_set_object_terms() here
}

This way, the taxonomy is guaranteed to be available when your function is run. It solved the problem for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.