Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a WPMu installation on a closed network, and one blog is using the K2 theme, but the Text Widget is not offered as an option. When I switch the theme to Default, the Text Widget is offered. If I use K2 on another blog in the installation, I can see the Text widget. Any ideas on why the Text Widget won't work on K2 on this specific blog?

share|improve this question
    
Try disabling all plug-ins on that specific blog. One or more might be interfering with K2. –  EAMann Sep 8 '10 at 20:53
    
I tried that, no luck :( –  danhgilmore Sep 9 '10 at 19:16
    
Did you also disable all network-wide plugins as well as blog-specific plugins? –  John P Bloch Nov 9 '10 at 13:42

1 Answer 1

A reason for this can be that the Widget configuration data (that is what is stored into the database) is mixed-up on that certain blog. Those cases are hard to debug. What you can try is to reset all widget settings on that blog. Sometimes it's enough to remove the Text-Widget from the lower pane if it is available there. If not, remove the widget configuration from the database (backup first!). After that, the Text-Widget should be offered again.

Another problem could be something related to javascript. That's just a guess, but to play safe here, just disable javascript in your browser and then use the widget screen. It has a new design as it offerers now widget configuration in a non-js variant. You probably can setup the TextWidget here. So try this first even if you do not have a javascript problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.