Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I tried to install a premium theme called Superb. I'm new to WordPress and I'm having a bit of a problem. I think that it has to do with permission settings, but I'm not sure. This is my situation:

I'm on a Mac running MAMP Pro. I've setup WP on my local machine. When I open my site in a browser, I see the default WordPress page. So far, so good.

I unbundled the Superb zip file and put the directory in wp-content --> themes. I went to WP's dashboard Appearance--> Themes, but Superb was not visible. There was no picture of the theme and no nothing to activate.

So I changed the Superb directory's permissions to Me: Read & write, Everyone: Read only. Now, the Superb theme is visible. I activated the theme.

When I opened the browser, I got these error messages at the top of the page and then the default page styled with the Superb theme:

Warning: include(recaptchalib.php) [function.include]: failed to open stream: Permission denied in /Users/myname/Sites/mysite/wp-content/themes/Superb/uContact/contact.php on line 136

Warning: include() [function.include]: Failed opening ‘recaptchalib.php’ for inclusion (include_path=’.:/Applications/MAMP/bin/php5.2/lib/php’) in /Users/myname/Sites/mysite/wp-content/themes/Superb/uContact/contact.php on line 136

Now, I can't even login into wp-admin and there are lots of warnings as above.

I think that I'm doing something wrong with the permissions. Maybe I made some other idiotic mistake. If someone can give me detailed instructions on how to solve this problem on a Mac, I would be psyched.

Thank you!

-Laxmidi

share|improve this question
    
Show us line 136 of the contact.php. –  toscho Apr 22 '11 at 16:47
    
Hi @toscho, Thank you for the message. The code looks like this: code// Basic init if(!is_admin()) { include 'recaptchalib.php'; } code The line starting "include" is 136. I included a couple extra lines in order to add more context. Thank you. –  Laxmidi Apr 22 '11 at 17:39
    
it looks like it's trying to load that file from your default include path and can't find it, maybe that filename needs to be appended with the themedir? –  Milo Apr 22 '11 at 18:04
add comment

4 Answers

up vote 1 down vote accepted

Laxmidi:

You wouldn't FTP to your local installation of WordPress, which is under some directory that you have assigned with MAMP.

Wherever that directory lives, you must unpack your theme.zip folder on your desktop, then move the theme into /wordpress/wp-content/themes

Once you add move your downloaded theme directory into WordPress, you should see the Theme under Dashboard -> Appearance -> Themes, after which you will activate it, then navigate to the local URL and see your WP install working.

All files should be 644 and all folders 755.

Tony Zeoli

share|improve this answer
    
Hi Tony, Thanks for the help. The problem was with the recaptchalib.php file permission. –  Laxmidi Apr 22 '11 at 21:35
add comment

Your include path is missing the current directory .. This is a very common issue that the developer should know. So either fix the include path or replace the include 'recaptchalib.php'; with include './recaptchalib.php'; or include dirname(__FILE__) . '/recaptchalib.php';.

share|improve this answer
    
better yet: include( get_template_directory() . '/recaptchalib.php' ); –  Chip Bennett Apr 22 '11 at 18:46
    
@Chip Bennett No, the file is in /uContact/. ;) And dirname() is surely fast enough. –  toscho Apr 22 '11 at 19:07
    
Oh, it's a Plugin, or something? –  Chip Bennett Apr 22 '11 at 19:24
    
@Chip Bennett See the second comment on the question: It is in a subdirectory /uContact/ of the theme. But judging by the name it should be a plugin probably. Like 90% of the content of most premium themes … –  toscho Apr 22 '11 at 19:34
    
Ok, okay! So: include( get_template_directory() . '/uContact/recaptchalib.php' ); :) –  Chip Bennett Apr 22 '11 at 20:22
show 5 more comments

Like chip says for premium theme support its always bets to contact the developer, i've not come across one yet who isnt happy to help (maybe im lucky).. little pointer though seeing as your new to wordpress when uploading the theme via the install theme tab be sure that your uploading the actual theme zip, meaning some themes these days are so huge that they can be double or triple archived even

share|improve this answer
    
Hi @Martin, I think that the theme developer will help me out. But, I probably won't get a reply until Mon. Hope to solve before then. Thanks for the reminder about the zip file. I did remember to use it. I need to figure out where to get the FTP username and password on my local machine. Any suggestions would be really appreciated? Thank you! –  Laxmidi Apr 22 '11 at 17:51
add comment

First, since you're using a premium Theme, you should first consult the Theme developer's support offerings.

That said, I would try installing the Theme through WordPress, rather than manually:

  1. Delete the existing Theme folder in wp-content\themes`
  2. Go to Dashboard -> Appearance -> Themes, click the Install Themes tab, then the Upload sub-tab.
  3. Upload/install the Theme using the form.

And if that still fails, check your file permissions. I believe \wp-content\ and sub-directories should pretty much all be 755?

share|improve this answer
    
Hi Chip, Thank you for your message! I contacted the theme devs, but they're in Europe and closed for the day. I deleted the theme. I clicked the install tab as you mentioned. I got an error asking whether the parent file was writable. I changed wp-content's permission to Me: "Read & Write", (unknown):"Read Only", and everyone: "Read & Write". I tried to change (unkown): to "Read & Write", but no luck. In any event, with the permission change, I've made it to "Connection Information". It's asking me for FTP Username and FTP Password. Where would I find this for my local machine? Thank you! –  Laxmidi Apr 22 '11 at 17:34
    
Hi Chip, I ran out of space. I've only done an FTP to a production server. How do I do an FTP on my local machine? The Hostname is: mysite. I'm not sure what the FTP Username and FTP password is. Is the FTP password the same as what I use to fire-up MAMP Pro. I really appreciate the help. I'm stumped. Thanks. –  Laxmidi Apr 22 '11 at 17:37
1  
if it's asking for ftp info, the apache user is not the same user as the one running the wordpress process. –  Milo Apr 22 '11 at 17:42
    
Hi @Milo, Thank you for your message. Where would I find the apache user details for my local machine? When I turn on the webserver, I click the MAMP symbol. It prompts me for a password which I input, and then it starts up. Is that the password your referring to? If so, how do I find my user name? I appreciate your help. Thanks. –  Laxmidi Apr 22 '11 at 18:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.