Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've just set up a new multisite installation. Everything works as I'd except that images don't show up on any of the sub-sites.

Any idea why the images don't show up?

I'm running Wordpress 3.1.1 on IIS6 in a shared Windows server (hosted by Arvixe.com). The secondary sites are in sub-directories rather than sub-domains. The images for the main site work, as does the header image, but the images in sub-sites don't appear.

I know that the images are uploading properly as they appear in the blogs.dir folder on the server. They also show up if I navigate them like this:

http://www.example.com/test/wp-content/blogs.dir/5/files/2011/04/LazyDog.jpg

However, they don't work when I navigate to them like this:

http://www.kramii.com/test/files/2011/04/LazyDog.jpg

When I try this second version in IE I get the broken image icon, whereas in Firefox I get just the filename at the top of the screen. Interestingly, when I show the page info in Firefox it shows type as "image/jpeg", which suggests to me (and I might be wrong) that the server has found the image and is attempting to send it to the browser.

My web.config looks like this:

In my settings for the site I've got:

I've disabled all plugins.

One final note: someone on another site had a similar problem and someone else replied "Is your webhost using a caching mechanism or proxying your webtraffic?". Quite honestly I don't really understand what this means. How would I know? What can I do if they are?

Thanks.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Finally, I've got it!

Sniffing the HTTP resonses indicated that a few extra bytes were being inserted between the headers and body of the http response, resulting in bad image data.

Further investigation revealed that these characters represent a Unicode Byte Order Mark (BOM).

These, in turn, were caused by a Windows editor that saved wp-config.php with a UTF-8 encoding that includes the BOM. Re-saving the wp-config file using a editor (Notepad++) that can strip the BOM resolved the problem. The only additional requirement was to flush the browser cache to clear the bad response.

I hope this helps someone else who has a similar problem. It has taken me literally hours to fins the answer, but I've learned a lot on the way.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.