Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am pretty new to web design, so this is a perplexing problem to me. I am creating a floating social media share button to the left of my content that scrolls with the blog content. Here is the code I am using:

<div id="floating-menu-blog" style="opacity:0.3;filter:alpha(opacity=30)"
onmouseover="this.style.opacity=1;this.filters.alpha.opacity=100"
onmouseout="this.style.opacity=0.3;this.filters.alpha.opacity=30">

<div class="float-title">
<iframe src="http://platform.twitter.com/widgets/tweet_button.html?url=<?php echo      rawurlencode(get_permalink()) ?>&amp;text=<?php echo  rawurlencode(strip_tags(get_the_title())) ?>&amp;count=vertical" style="width:55px;  height:62px;" frameborder="0" scrolling="no"></iframe>
</div>


<div class="float-title">
<script type="text/javascript">var fbShare = {
url: <?php the_permalink() ?>,
size: 'large',
badge_text: 'fff',
badge_color: '3b5998',
google_analytics: 'true'
}</script>
<script type="text/javascript" src="http://widgets.fbshare.me/files/fbshare.js">      </script>

And here is what is in my css file:

/*float social media buttons*/
#floating-menu-blog {background-color:#fff;border:1px solid #ccc;position: fixed; left: 50%; top: 342px; margin-left:-554px; z-index:100;}
#floating-menu .float-title{padding:1px 3px;}
#floating-menu .float-title a{color:#000;text-decoration:none}

However, on the site, the css is not being applied at all. I cleared all caches and disabled w3total cache to make sure that wasn't the issue. I have no clue what the issue is as it was working a week ago and I really haven't changed anything in relation to this code.

Please let me know if I can provide more info. Thanks!

share|improve this question
    
what is the browser seeing? have you installed firebug in firefox to check what CSS files are actually loading? –  Mild Fuzz Apr 20 '11 at 13:07
    
Screenshots would also be VERY helpful. As Mild Fuzz said, Firebug is a great place to start. –  ZaMoose Apr 20 '11 at 13:10
    
Also, I would use the :hover meta parameter instead of the onmouseover/onmouseout stuff. –  ZaMoose Apr 20 '11 at 13:10
    
Wow. 0% accept rate? No thanks! I can understand less than 75%, but 0%? Good luck buddy. –  John P Bloch Apr 20 '11 at 13:25
    
Thanks for the help. I figured it out. Basically, it was a plugin conflicting with the last portion of my css files. I appreciate the help. As for John Bloch, go ahead and answer my questions if you want to see the acceptance rate go up: wordpress.stackexchange.com/questions/8307/… (not answered), wordpress.stackexchange.com/questions/7296/… (not answered), and my other two questions were asked before the accept an answer option was available. Just responding to a douche response with a douche answer –  Jeff Apr 20 '11 at 13:44

1 Answer 1

up vote 0 down vote accepted

A plugin conflicted witt eh last 30 lines or so of my css file. No idea what exactly it did to cause this, but disabled the plugin and everything is solved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.