Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

one of my site's wp-admin is not accesible but the site front part is loading. This happens after i accessed the site from my new server second time. at first nothing happens and i can logg into dashboard. then after i logged out and second time try to login this error happens. when accessing the mysite.com/wp-admin the page shows

The page isn't redirecting properly.Firefox has detected that the server is redirecting the request for this address in a way that will never complete.
This problem can sometimes be caused by disabling or refusing to accept cookies.

in the public_html/error_log :

PHP Warning:  require(/home/mysite/public_html/wp-includes/pomo/mo.php) [<a href='function.require'>function.require</a>]: failed to open stream: Permission denied in /home/mysite/public_html/wp-settings.php on line 76
PHP Fatal error:  require() [<a href='function.require'>function.require</a>]: Failed opening required '/home/mysite/public_html/wp-includes/pomo/mo.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/mysite/public_html/wp-settings.php on line 76

cpanel error_log shows:

Permission denied: /home/mysite/public_html/wp-admin/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable

the htaccess have 644 permission. but i changed it into 775 and 755 and checked. the same happens. what could be the reason? how to solve this?

share|improve this question

1 Answer 1

there is a missing.. a file which is required wordpress is missing so admin is not working properly to fix it just replace your wp-include folder with the exact version you have or there could be some permission issue just check all file has 775 as the permission

share|improve this answer
    
okay..let me check..and will inform u.. –  Ammu Jun 27 at 10:17
    
no hope.. :( i've re-uploaded the copy and permission changed to 775. but still shows same. –  Ammu Jun 27 at 11:43
    
check for folder permision –  S.Varun Jun 27 at 11:44
    
folder permission also changed to 775.. please find my updated post. i have added more details. –  Ammu Jun 27 at 11:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.