Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

my wordpress site moved to a new server with cpanel. now after logged into wp-admin an error is showing.

call_user_func_array() expects parameter 1 to be a valid callback, function 'showEntry' not found or invalid function name in /home/mysite/public_html/wp-includes/plugin.php on line 406

can anybody please tell me why this is showing and how to solve this?

ok..i found out there this is related to a plugin. but i don't know the reason. please help me to find the reason why this is showing. the plugin part that contains this function is listed below: the plugin name is clinic

clinic.php

add_action('admin_print_scripts', 'showEntry');

appointment-book.php

<select name="eemail_subject_drop" id="eemail_subject_drop" onchange="showEntry(this.value)">
                <option value="">Select Email template</option>
  <?php echo $eemail_subject_drop_val; ?>
            </select>

settings.js

function showEntry(id)
{


 jQuery(document).ready(function($) {

var data = {
    action: 'template_action',
    id: id

};

// since 2.8 ajaxurl is always defined in the admin header and points to admin-ajax.php
jQuery.post(ajaxurl, data, function(response) {
    //alert('Got this from the server: ' + response);
     jQuery('textarea#mail_contents').text(response);
     });
     });
    }

view-subscriber.php

<select name="eemail_subject_drop" id="eemail_subject_drop" onchange="showEntry(this.value)">
                <option value="">Select Email template</option>
                <?php echo $eemail_subject_drop_val; ?>
            </select>

what is the error in these files. this warning happens when the site is moved to a new server with cpanel. please help me to solve this.

share|improve this question
1  
Did the database get copied over correctly? Are the correct theme/plugins enabled? What is "showEntry"? –  czerspalace Jun 24 at 6:08
    
yeah..everything is working perfectly. including cforms plugin. i don't know sir what is this showEntry. i checked that function in my theme function.php also but didn't find. –  Ammu Jun 24 at 6:19
    
Shot in dark here, did you flush your permalinks after the migration. showEntry uses $url... –  Pieter Goosen Jun 24 at 7:10
    
flush permalinks means? i just make in default and again make it as postname. is that u mean? sir, can u plz tell me what to do for that.. –  Ammu Jun 24 at 7:44
    
Could you do a search across all files in wp-content for "showEntry"? –  engelen Jun 24 at 8:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.