Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

My issue is prety much what the title indicates. Whenever I publish a new post, everything works fine - the post is listed in my WP dashboard and all looks good. However, if I try to 'view post' to view it live on my website,

I've searched for this issue throughout the net, and all point into editing the .htaccess file. However, this issue is more likely related to a theme I've developed (why? because several buyers have reported this issue, so I need to find a fix for the theme itself).

That said, editing or manipulating the root .htaccess file is not really an option as the issue is originated in my theme.

Best,
Chris

share|improve this question
    
If you navigate to your site's homepage, you see the post listed correctly? And if so, does that link also throw a 404 error? Also: to figure out if it is your theme or not, temporarily set your theme to the default Twenty-Ten WordPress theme to see if that resolves your problem. –  Evan Wondrasek Apr 18 '11 at 18:35
    
Indeed, the post shows up in my blog as any other post, but if I click on its permalink to view the whole post, it returns a 404 error. The same happens if I try to view the post live from the back-end. In other words, whenever you visit the post's actual link, it shows a 404 error. –  cr0z3r Apr 18 '11 at 18:43
    
What happens if you use a different theme, like the default WordPress theme "Twenty Ten" (should be included by default). I just want to narrow down whether your theme would cause this problem or if it's just something with your permalink rewriting. –  Evan Wondrasek Apr 18 '11 at 18:46
    
Hey Evan, thanks for your help. I haven't been able to try the Twenty Ten theme approach, as I haven't been able to recreate the 404 error again. Meaning, this issue occurs on a random basis. Here's kind of what's happening to me: abing.gotdns.com/posts/2006/… –  cr0z3r Apr 18 '11 at 19:37

1 Answer 1

up vote 1 down vote accepted

I just ran into something similar to this. It had to do with refreshing permalinks. If you go to Settings -> Permalink and just click save see if it fixes your problem. It did for me. In the end I added the following to my functions.php file which updated the permalinks for me. I was using custom post types. Maybe you have a plugin that is doing the same.

add_action('admin_init', 'flush_rewrite_rules');
share|improve this answer
    
Hey thanks, in fact, I was wondering why my issue was 'gone' and I had also re-saved my Permalinks. Althought I can't be certain about whether it's truly fixed, as some users have reported that this issue can present itself one every year, or so. –  cr0z3r Apr 20 '11 at 4:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.