Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm new to Wordpress and am creating a site using v3.9.1 of WordPress. When I create a new page, I can see it in edit mode, but the URL it is supposedly creating is not found when permalinks is used, but visible when permalinks is disabled. For example, if I try to create a page called photos right below the top level, the editor states the page will be visible at http://example.com/photos/ when permalinks is Post name, but navigating to such page gives the error:

Not Found

The requested URL /photos/ was not found on this server.

But if I put Permalinks back to Default then it becomes visible at http://example.com/?page_id=4.

share|improve this question
    
Go to your Admin Backend, General Settings. What are the values for WordPress Address (URL) and Site Address (URL)? –  eyoung100 Jun 12 at 22:12
    
ok and what is your actual domain name? –  eyoung100 Jun 12 at 22:16
    
Ok, you need to login to your Host Control Panel, and Delete the Database attached to your install then empty out your root directory, then reinstall WordPress as I am getting the ApacheHaus landing page... nothing related to WordPress –  eyoung100 Jun 12 at 22:22
1  
@ECarterYoung WordPress does not have to be installed in root for the site to appear in root of domain, that's why there are separate WordPress address and Site address settings. See Using a pre-existing subdirectory install in Codex. –  Milo Jun 12 at 23:03
1  
@WilliamKF - 1. verify that your server has mod_rewrite 2. make sure WordPress can create an .htaccess file 3. make sure your server is set up to parse .htaccess files. You may need to ask your web host these questions. See Using Pretty Permalinks in Codex. –  Milo Jun 13 at 1:23

1 Answer 1

up vote 1 down vote accepted

This is a Site I maintain hosted on GoDaddy. All HTML seen by the outside world is stored in the /public_html directory. Therefore /public_html is considered the root directory of my server.

FileZilla Photo

This site runs on WordPress 3.9.1. All that was done, was that GoDady's custom installer package unzipped the WordPress download zip to the /public_html directory. Doing this Manually is easily accomplished by unzipping the WordPress download to a Folder and then uploading the contents of that Folder(but not the folder) to your web root. I suspect you unzipped and then uploaded the containing folder, which would lead to www.example.com/wordpress if wordpress was the folder you uploaded.

To fix this, work backwards...

share|improve this answer
    
I'm missing how this helps to resolve my issue. –  WilliamKF Jun 12 at 23:09
    
By redoing your WordPress install in the manner I describe, you will avoid having to use the .htaccess file If redoing the install is not Possible, see @Milo s comment above. –  eyoung100 Jun 12 at 23:12
    
Complete reinstall twice now, and same issue each time, new pages do not show up, not found when visiting them. Could iThemes plugin be the cause? –  WilliamKF Jun 13 at 0:37
    
Looks like enabling permalinks is causing this. –  WilliamKF Jun 13 at 0:48
    
Check the Codex –  eyoung100 Jun 13 at 14:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.