Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm running Apache + Cpanel with PHP installed as an apache module. I've been trying to setup W3 Total Cache to see the php and apache extensions, and I've been having trouble. It detects curl and ftlib, but it can't detect any of the extensions from mod_deflate to mod_setenvif. While these will work even if they're "not detected", it also doesn't detect either apc or memcache, and I'd like to use some combination of caching plugins

php -r 'phpinfo();' | grep -i 'apc'

apc
APC Support => disabled
APC Debugging => Enabled
MMAP File Mask => /tmp/apc.XXXXXX
apc.cache_by_default => On => On
apc.canonicalize => On => On
apc.coredump_unmap => Off => Off
apc.enable_cli => Off => Off
apc.enabled => On => On
apc.file_md5 => Off => Off
apc.file_update_protection => 2 => 2
apc.filters => no value => no value
apc.gc_ttl => 0 => 0
apc.include_once_override => Off => Off
apc.lazy_classes => Off => Off
apc.lazy_functions => Off => Off
apc.max_file_size => 10M => 10M
apc.mmap_file_mask => /tmp/apc.XXXXXX => /tmp/apc.XXXXXX
apc.num_files_hint => 4096 => 4096
apc.preload_path => no value => no value
apc.report_autofilter => Off => Off
apc.rfc1867 => Off => Off
apc.rfc1867_freq => 0 => 0
apc.rfc1867_name => APC_UPLOAD_PROGRESS => APC_UPLOAD_PROGRESS
apc.rfc1867_prefix => upload_ => upload_
apc.rfc1867_ttl => 3600 => 3600
apc.serializer => default => default
apc.shm_segments => 1 => 1
apc.shm_size => 32M => 32M
apc.shm_strings_buffer => 4M => 4M
apc.slam_defense => Off => Off
apc.stat => Off => Off
apc.stat_ctime => Off => Off
apc.ttl => 7200 => 7200
apc.use_request_time => On => On
apc.user_entries_hint => 4096 => 4096
apc.user_ttl => 7200 => 7200
apc.write_lock => On => On

php -r 'phpinfo();' | grep -i 'memca'

memcache
memcache support => enabled
memcache.allow_failover => 1 => 1
memcache.chunk_size => 8192 => 8192
memcache.default_port => 11211 => 11211
memcache.default_timeout_ms => 1000 => 1000
memcache.hash_function => crc32 => crc32
memcache.hash_strategy => standard => standard
memcache.max_failover_attempts => 20 => 20
Registered save handlers => files user memcache 
PWD => /usr/local/src/memcached-1.4.6
_SERVER["PWD"] => /usr/local/src/memcached-1.4.6
_ENV["PWD"] => /usr/local/src/memcached-1.4.6

So I asked a question that might be relevant over here: Zend Opcache No Files Cached

Zend Opcache doesn't see any of my PHP files in the wordpress installation. W3 Total Cache can't seem to see any of my installed php modules. I'm flummoxed. Does anyone have any ideas? Let me know if anything else would be helpful.

Domain is openproto.us, if that helps any.

share|improve this question
    
Are you sure that both applications are run by the same (server) user? –  kaiser Jul 28 at 14:35

1 Answer 1

up vote 0 down vote accepted

This turned out to be an issue between a php.ini file in my wordpress installation and the system's php.ini file. Wordpress will use the one in its directory and ignore everything in the system php.ini file. Deleting the wordpress php.ini file fixed the issue.

share|improve this answer
    
technically, WordPress has nothing to do with this, it's php that loads the .ini file. –  Milo Jul 17 at 0:28
    
I might be wrong, but I believe wordpress gave the command to load php with that particular php.ini file, as everything else seemed to use the system one. However, I have very little knowledge of PHP, so you're probably right –  cii Jul 17 at 0:35
    
php apps can't control how php loads, because php is already loaded in order to execute the code. a php app can only change certain settings loaded by the configuration, but can't choose what configuration to load. –  Milo Jul 17 at 1:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.