WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just upgraded my wordpress installation from 3.1 to 3.1.1 and my custom structure permalinks are now broken,

The permalinks were set to follow this procedure,


however now they are just falling back to


How can I fix this what has changed in 3.1.1 I wonder if it is a problem with my .htaccess file? Or maybe I am running on IIS?

share|improve this question

migrated from stackoverflow.com Apr 15 '11 at 19:53

This question came from our site for professional and enthusiast programmers.

Here are some steps for you

a) Access you site through ftp and remove .htaccess file (possibly backup it)

b) Go to admin of your site (wordpress admin) and open permalink settings form

c) set the first option to custom and put the value in text box


d) save changes and check you front-end for links

e) if proper links visible check one to view if they aren't returning 404

f) if you see 404 , put this line at the top of the .htaccess

 Options +FollowSymLinks

hopefully this will this the issue


share|improve this answer

If you are using Custom Post Types with the rewrite option you will want to flush your WP Rewrite rules after an upgrade. Adding this to your plugin or functions.php can help (tested with 3.4):

    // After an upgrade, flush rewrite rules
    function flush_rules_post_upgrade() {
        global $wp_rewrite;
        if( is_object($wp_rewrite) )
share|improve this answer

I think your .htaccess is no more getting updated from admin.

So try to update url re-writing code manually in .htacess.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.