Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Server: IIS 6
WordPress version 3.1.1
Multisite using SubFolders

I'm able to upload images to the server, but thumbnails and full size images do not display. If I try to edit the image, the preview displays. The file exists in blogs.dir. I'm using ISAPI Rewrite to create a httpd.conf file, which contains the block of code listed under Subfolder Example on the Create a Network page in the Codex.

WordPress says the file is here: http://blogs.nvcc.edu/test/files/2011/04/facebook6.jpg.

Actual location is here: http://blogs.nvcc.edu/wp-content/blogs.dir/32/files/2011/04/facebook6.jpg

So many clues... I just can't put it together.

Any help is greatly appreciated

--Damon

share|improve this question
1  
Have you checked the media path save settings under Settings > Media? –  Chad Von Lind Apr 15 '11 at 17:22

1 Answer 1

Go resave your Permalink settings to correct the .htaccess file.

Multisite systems have a slightly different .htaccess configuration. Specifically, they have this line in them:

# uploaded files
RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

That lets the /files/whatever URLs get routed to the proper location.

Edit: sorry, just noticed you're using ISAPI Rewrite. Create a new rewrite rule in your config similar to the .htaccess rule above.

share|improve this answer
    
Beat me to it ... :-) Exact same answer. –  EAMann Apr 15 '11 at 18:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.