Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm getting the following error:

PHP Syntax Check: Parse error: syntax error, unexpected 'qtip' (T_STRING), expecting ')' in your code on line 14

in this code:

<?php
// Always use wp_enqueue_scripts action hook to both enqueue and register scripts
add_action( 'wp_enqueue_scripts', 'enqueue_and_register_qtip_scripts_and_style' );

function enqueue_and_register_qtip_scripts_and_style(){

    // Use `get_stylesheet_directoy_uri() if your script is inside your theme or child theme.
    wp_register_style( 'qtip', get_stylesheet_directory_uri() . '/qtip-js/jquery.qtip.min.css', 'all' );
    wp_register_script( 'imagesloaded', get_stylesheet_directory_uri() . '/qtip-js/imagesloaded.pkg.min.js', true );    
    wp_register_script( 'qtip', get_stylesheet_directory_uri() . '/qtip-js/jquery.qtip.min.js', array('jquery', 'imagesloaded'), false, true );
    wp_register_script( 'tooltip', get_stylesheet_directory_uri() . '/qtip-js/tooltip.js', array('jquery', 'imagesloaded', 'jquery-qtip-min), false, true );

// Add the styles first, in the <head> (last parameter false, true = bottom of page!)
   wp_enqueue_style( 'qtip', null, false, false );

// Using imagesLoaded? Do this.
wp_enqueue_script( 'imagesloaded', null, false, true );
wp_enqueue_script( 'qtip', false, true );
wp_enqueue_script( 'tooltip', false, true );
}
?>

The 14 line says: wp_enqueue_style( 'qtip', null, false, false );

Your help is much appreciated.

share|improve this question

closed as off-topic by Pieter Goosen, toscho Jun 6 at 18:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – Pieter Goosen, toscho
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I'm very new to coding so thank you for the tip Pieter. –  user52826 Jun 6 at 18:48

1 Answer 1

up vote 1 down vote accepted

The problem is that you forgot a apostrophe after 'jquery-qtip-min)

wp_register_script( 'tooltip', get_stylesheet_directory_uri() . '/qtip-js/tooltip.js', array('jquery', 'imagesloaded', 'jquery-qtip-min), false, true );

should be

wp_register_script( 'tooltip', get_stylesheet_directory_uri() . '/qtip-js/tooltip.js', array('jquery', 'imagesloaded', 'jquery-qtip-min'), false, true );

I know that sometimes you can look over such things, especially if (maybe) you aren't an experienced coder, but still please try harder next time to spot such really simple typos before posting questions on WPSE.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.