Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am working on WordPress permalinks. I wanted to change the permalink URL from

xyz.com/abc/locations/18 (which is location id)

to

xyz.com/abc/locations/locationname

With locationid the page is loading perfectly but when I change to locationname the page is giving a 404 error.

share|improve this question
1  
Is this a custom post type? Default Posts? How do you change it? –  kraftner Jun 2 at 12:25

1 Answer 1

Seems you have not set the permalinks correctly..

Delete your .htaccess file and try setting permalinks to postname enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.