Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm using the Illustratr theme. On the home page of my blog it says:

"NOTHING FOUND. It seems we can’t find what you’re looking for. Perhaps searching can help.", 

This appears since I created it. It only shows on that first page, which is static, and where I have only a gallery. Also when I post other content on that page, it stays there. I don't know much about the coding, so changing the template is not really an option...

Thank you!

share|improve this question
    
A quick Google search for illustratr theme wordpress seems to indicate that this is a wordpress.com theme. Are you trying to use it on a self-hosted WordPress installation, or are you have trouble using it on WordPress.com? If the latter, please consult their support site -- WPSE's help pages specifically indicate wp.com support is outside this site's scope. –  Pat J May 30 at 19:01

1 Answer 1

Create a page for you Blog. Just the title only nothing else. I use 'Our Blog' for instance. Save it and make it public.

In your dashboard go to Settings|Reading

Use the drop down menu for "Post Page" to find the page you just created.

Scroll down and save the changes.

Your blog page should now show up in the site navigation menu and any blog posts should show up on that page.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.