Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have moved a Wordpress install to a client from sub folder to the root folder. Right now, everything works fine, except for the friendly URLs. I currently have to set the Permalink feature in "Common settings" to "Default", which means URLs with ?p=434... At least they work. Otherewise I get a very short 404 not found error message on a white screen. I was following this tutorial, but I found I cannot write an .htaccess to my Yahoo host account and so I could not follow one of the last steps... I wonder if the 404 not found errors have to do with this problem I have had uploading the .htaccess file... I currently do not have any .htaccess file up there... So maybe MOD_REWRITE is disabled... I have just ran phpinfo() and did not find any entry on mod_rewrite. Before moving the website, when it was still on a subfolder, the friendly URLs used to work, but now they don't. Has anyone came accross this experience and has successfully restablished the permalinks feature?

Any help is appreciated. Thank you.

share|improve this question

5 Answers 5

up vote 4 down vote accepted

Yahoo doesn't allow users access to the htaccess file which means that you can't the mod_rewrite rules needed for custom permlinks. The Only way around it that i've heard it works (never tried it myself) is to add /index.php/ to the beginning of your custom structure so: Go to Permalink Settings > Select Custom Structure. And set the value as /index.php/%postname%/ or what ever you want as long as you add /index.php/ before it.

Hope this helps.

share|improve this answer
    
Great, it works! Although the "index.php" isn't the most beautiful thing to be in the center of the URL, at least I have an option to the raw querystrings... Thank you. –  Marcos Buarque Apr 12 '11 at 21:35
    
Glad i Could help –  Bainternet Apr 12 '11 at 21:54

In the Yahoo Small Business Account Manager look for "Blog Manager". There it will give you an opportunity to enter the new file path. That should do it in most cases.

Do not deactivate or remove this plugin as it seems to be required by the WordPress Installation provided by the Yahoo Auto-installer. In case you do, temporarily put up a secondary blog through the blog manager and copy the required files from the temporary plugin directory to your main blog directory. When done simply use the Blog Manager to deactivate (remove) the temporary blog.

share|improve this answer

If you used the Yahoo! WordPress automatic installer for your client's installation, you can also create custom permalinks for your account by going into your WordPress Dashboard > Appearance > Plugins section and activating the Customizable Permalinks plugin.

Please note: the Customizable Permalinks plugin assumes that the installation is still located in its initial directory. If you've moved the installation, or if you you didn't use the automatic installer, you might check the WordPress Plugins archive (http://wordpress.org/extend/plugins/) for customizable permalink plugins that don't require .htaccess.

share|improve this answer

If you can set up custom error pages use the index.php as 404 page. Now you can use regular permalinks on a single site installation.

share|improve this answer

I fixed this by going to the Yahoo control panel > Manage > Blog Manager

click "did your links change?" click "update blog manager links", change the folder and hit "update"

go back into the wordpress control panel > settings > permalinks don't change anything, just hit "save changes"

and all my permalinks are working!

John

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.