Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I want to convert my site from Drupal to WordPress. I installed WordPress in a subdirectory so I can tweak it until I'm ready to delete drupal and move it to the root folder. After installing I cannot access the WP index in the subdirectory. I get this in firefox:

"The page isn't redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

*   This problem can sometimes be caused by disabling or refusing to accept
      cookies."

I have cleared my browser and still get the same error. It must have some conflict with drupal. The drupal part of the site is still working ok.

When I try to load my WP admin login url in the subdirectory it loads ok, but as soon as I submit my username and password, it redirects me to the login again.

Any clues? Thanks

UPDATE: I contacted my host and the problem was WP was not creating an .htaccess file when installing to a subdirectory. I tried installing WP a few times and it would never create an .htaccess file within the subdirectory. I'm using hostgator. I don't know if it was because there already was an .htaccess in root (from drupal) or something to do with my host.

share|improve this question
    
Delete your cookies –  Wyck Apr 9 '11 at 3:56
    
I tried that before I posted this –  Tony Clifton Apr 9 '11 at 18:09

2 Answers 2

It sounds like your .htaccess file isn't configured correctly. Your root level htaccess file will take priority over the one in the WordPress folder.

Try telling Drupal to ignore your subfolder by adding this to the rewrite statement at toward the bottom (of the default Drupal .htaccess file), after the line that says "ReWrite Engine On"

RewriteCond %{REQUEST_URI} !^blog

where "blog" is the subfolder that you've installed WordPress to.

share|improve this answer
    
Thanks for the advice and I didn't even realize there was supposed to be an .htaccess file in the subdirectory. It was not installing one. That was the issue, see above. –  Tony Clifton Apr 9 '11 at 18:12

Not sure if you can do this on your hosting provider, but on our Apache server we added this to the httpd.conf file:

<Directory /home/.../wordpress/>
  DirectoryIndex index.php
  Options FollowSymLinks -Indexes -MultiViews
  AllowOverride All
</Directory>

and in the .../wordpress/ folder, we created a blank .htaccess file writable by the group "apache" so WordPress can update it.

This allowed the .htaccess file in the /wordpress/ folder to override the one in the parent (root) folder.

Hope this works for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.