Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Using WP 3.1.1 as a CMS, using the Boldy theme.
Home page is at http://www.dekho.com.au

Advantage of using this theme, is that it comes setup with a homepage that has a gallery slider and some homeboxes at the bottom.

To get to the blog, I had to dump all my posts into a category called blog.
- The themes docco advises to do this]3.
I can then link to this blog category from the top menu.

This then passes me to this URL: http://www.dekho.com.au/?category_name=blog

I want to know how to retain the home page provided by Boldy, but have the blog on a separate page with the following URL:
dekho.com.au/blog

share|improve this question

1 Answer 1

up vote 2 down vote accepted

First, you need to change your Front Page settings:

1) Create a Static Page, called "Blog" (and a slug of "blog")

2) Create another Static Page, to serve as your site Front Page

3) Go to Dashboard -> Settings -> Reading

4) Change "Front Page Displays" from "Your latest posts" to "A static Page (select below)"

5) In the "Front Page" dropdown, select the Static Page that you created to serve as your site Front Page

6) In the "Posts Page" dropdown, select the Static Page "Blog"

Next, you need to fix your permalinks:

1) Go to Dashboard -> Settings -> Permalinks

2) Select one of the default options ("Month and Name" is usually good)

3) Save settings, to write the rewrite rules to .htaccess

Now dekho.com.au/blog should be displaying your blog posts index

share|improve this answer
    
This sounds like the correct answer, but perhaps not for my Boldy theme? wordpress.site5.net/boldy/doc I have not actually created a page for the home page, a homepage is built into it. I created a static page called blog If I choose FP displays static page, leave front page blank and choose blog for posts = does not work. If I choose a different page for front page, I lose my original homepage with image slider. –  Simon Apr 9 '11 at 1:36
    
Boldy does it wrong. It uses the home.php template file (which is intended to be used for the blog posts index) for its custom Front Page, when it should be using front-page.php (which is intended always to be used for the site Front Page, whether displaying the blog posts index or a static Page). The simplest solution would be to rename home.php as front-page.php. –  Chip Bennett Apr 9 '11 at 4:42
    
This would likely have a knock on effect elsewhere? I will have to do some testing on a dev box. –  Simon Apr 9 '11 at 6:49
    
It shouldn't have any ill effects. The blog posts index will revert to using the index.php template file, and your Front Page will be using the front-page.php template file, as desired. –  Chip Bennett Apr 9 '11 at 12:52
1  
Think of it more as a placeholder than a "dummy page". When you assign that Page as the Front Page, WordPress automatically uses the correct template file, i.e. front-page.php. –  Chip Bennett Apr 11 '11 at 11:17

protected by toscho Aug 11 '12 at 9:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.