Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

all. I am having a users-related problem on a multi-author site (actually two sites on a multi-site, both of which have the same users). Here are some details:

1) In the backend users' list, the number of users in parentheses at the top is correct (5), but in the actual list, only two appear.

2) The problematic users can sign into the admin. However, one of them can see only the left column; the main content area of the admin remains blank for him. We'll call him "User 1." Oddly, the only other active user of the "problem users" is still able to post.

3) On the front end, on one site of the multisite, existing posts show up fine, even by User 1. On the other site, however, posts by User 1 are missing. That is, the actual full post page is missing. The post appears on the archive page, complete with the user's name, but the single post page renders the title but not the content.

4) On the (static) front page, I am using a WP excerpt query in order to render excerpts of the most recent five posts. This renders fine until it hits the first excerpt it's supposed to show from User 1, at which point the page stops rendering, with the result that his excerpt as well as the sidebar and footer (both of which come later in the HTML) do not render.

This seems to have started while User 1 was editing his profile, so I'm considering creating a temporary user, deleting his profile in the database (can't delete it in the admin, since it's not actually appearing in the list) and assigning his posts to the temp, then re-creating his user account to see if that fixes the problem. But someone else perhaps has better ideas.

I'm currently running 3.9, but it seems that User 1 problems started before the upgrade.

share|improve this question

1 Answer 1

It appears that at some point the plugin Simple Local Avatars broke things. Disabling it solved my problem. I now have a user that I need to find another avatar solution for, as he doesn't have a Gravatar and using his other WordPress blog email address didn't import his photo.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.