Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When doing an automatic upgrade, I get this:

Downloading update from http://wordpress.org/wordpress-3.1.1.zip

Unpacking the update…

Could not create directory.: /public_html

Installation Failed

All my wp files are in /public_html and the directory already exists. The FTP user I am logging in as owns all the Wordpress files, so it cannot be a chmod problem. Is there any reason why this error is occurring?

share|improve this question
    
Where are you unpacking the zip file? On your server directly? Are you exporting the files to a directory that does not exist? Please tell us more about your process. –  Jonnybojangles Apr 6 '11 at 18:24
    
I am using the Automatic Upgrade feature in wp-admin. I have done dozens of upgrades like this before with no problem. It's this one installation that is causing problems. –  Jarred Apr 6 '11 at 18:33
    
Are you on a shared host or your own server? Could file permissions have changed outside of your control? –  Jonnybojangles Apr 6 '11 at 18:48
    
No, I have a dedicated server. All files are owned by the FTP user I am using. –  Jarred Apr 6 '11 at 18:58
    
I am at a loss, however I found this support article: wordpress.org/support/topic/30-upgrade-bug-ftps I suspect that you have already tried some of their suggestions? –  Jonnybojangles Apr 6 '11 at 20:58

2 Answers 2

up vote 0 down vote accepted

I had this problem and the answer was found (a) in enabling ftp to write and (b) at least temporarily setting the directories to 777 although I think the latter permissions can be improved.

I run vsftp with chroot'd users. After finding no mention in apache logs, setting the permissions to 777, changing ftp group to www-data, enabling anonymous ftp to write, tearing my hair out, kicking the dog etc etc the penny eventually dropped that ftp was not allowed to write. I also upgraded a multi-site to 3.1.1 and that needs 777 set (well probably less) but returns the files 640.

It may be that a changed ftp configuration has tripped you up.

share|improve this answer

The codex mentions:

Note that your files all need to be owned by the user under which your Apache server executes.

and

Automatic update has been known to fail if you're not using PHP5.

Codex: Automatic_Update

Additional, I found this Wordpress Support article featuring a similar problem for 3.x upgrades.

share|improve this answer
    
Yes, I have both of those. I have done automatic updates many times before. Only this particular one is failing. –  Jarred Apr 6 '11 at 18:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.