Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Thank you in advance for any help you might provide. I have read many other posts, and unfortunately the provided solutions did not work.

The problem is this: I have Wordpress installed in a supdirectory [http://www.example.com/wordpress] and would like to change the front end url to [http://www.example.com/somethingelse]

When I go to Settings > General and change the Site Address (URL) to [http://www.example.com/somethingelse] and check the front end, for [http://www.example.com/somethingelse], it returns a Wordpress custom 404 page. The permalink structure is [http://www.example.com/somethingelse/?p=123] and return a root 404 error.

I have made sure that the .htaccess is correct (although when I try to update permalinks with the new Site URL it says its not writable) and that the proper permissions are set.

Now, keeping [http://www.example.com/somethingelse] as the Site URL setting, if I go to the original [http://www.example.com/wordpress], the home page works, though all links show this structure [http://www.example.com/somethingelse/?p=123]

I have tried adding the URL define to wp-config.php of

define('WP_HOME','http://example.com/wordpress');
define('WP_SITEURL','http://example.com/somethingelse');

I have tried adding the following to my theme's functions.php

update_option('siteurl','http://example.com/somethingelse');
update_option('home','http://example.com/wordpress');

I have even tried changing both the Site URL and the Wordpress URL (checked it manually in the db to make sure it was correct) and changing the directory name to /somethingelse which gives me the white screen of death on every page.

I have tried disabling all plugins and redoing all of the above as well.

I am at a total loss as to what could be causing the errors as I can go over to my other Wordpress installs on the same server and change their Site URL with out any problem.

Any help would be greatly appreciated before I run out of hair ;)

Thank you again!

share|improve this question

2 Answers 2

You are sure there is no other error? I had almost the same problem last winter and after about 4 hours I noticed a syntax error in my config file, because I hit accidentally the "-" key.

If there is nothing wrong with that, I would try to restore all the old values and check if the website works with that. If yes, try again. If not, there is probably a mistake in your settings or on your server.

Have you checked if you (PHP) has access to write the .htaccess at its new position?

Maybe you want to post the URL (short link) so we can have a look at it.

share|improve this answer

Go to phpMyAdmin and select the database for the website. Go to the "wp_options" table and edit the first option (option_name: siteurl) from "http://www.example.com/wordpress" to "http://www.example.com/somethingelse".

In the same "wp_options" table, look for "option_name: home" and change the URL there too.

Now, rename your current .htaccess file to .htaccess_old and create a new blank .htaccess

Go to the URL and update the database when the system asks you to.

Let me know if this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.