Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

We have two versions of our site test.example.com running on nginx and our core site example.com running on Apache. The site is running for few year and has a lot of content and traffic.

We want to now to add multisite feature to our site, but to keep our core site running in the root domain. We enabled multisite, wildcard subdomains, etc. on test.example.com
site1.test.example.com shows,

'Welcome to nginx!

If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

For online documentation and support please refer to nginx.org. Commercial support is available at nginx.com.

Thank you for using nginx.'

Our questions are:

  1. What is the best practice to configure nginx and solve this common problem since there are so many different answers on this question.

  2. When we will be applying it on our core site example.com (on Appache), what will be different what we need to care of and what to do/not to do in that case.

  3. On the test.example.com the posts are giving error 404 after enabling multisite although they are normally showing up in the loop on main page. I hope it is related to nginx problem and will be solved with same fix, if not please, give me some lead to debug it.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.