WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just seen a new error message on one of my Wordpress sites that I've not come across before.

"This request has been denied for security reasons. If you believe this was in error, please contact support."

As usual, I hopped onto Google to see why this was coming up, but short of a few others also finding this message there's very little out there on this.

Does anyone know what it is? Is it new? A part of Wordpress?

It doesn't really offer much in the way of explanation. I'm guessing it's an IP ban of some sort, but I'm not sure where...

Boring error message

share|improve this question
up vote 3 down vote accepted

It could be that a plugin which blocks I.P addresses or Countries is causing this.

Otherwise it maybe a setting in a security plugin has caused this. Seems the message is a custom one.

Otherwise it could be something coded into a .htaccess file.

share|improve this answer

I'm experiencing the same problem.

It turns out that my IP address has been blocked by my web host. So each time this happens, I'll have to request them to whitelist my IP (as my ISP gives out dynamic IP addresses to broadband users in residential area, so it changes every now and then)

Hope this helps..


share|improve this answer

This is not a WordPress message, it is either from a plugin or from your web hosting. Disable all plugins (per file access, eg. FTP), try again. If it is gone, enable all plugins separately until it happens again.
Then remove the last plugin.

share|improve this answer

If you're using site5 hosting, they block simple passwords i.e. "123". Changing the password to something complicated fixed it.

share|improve this answer
had to talk to support still after changing – Sabrina Gelbart Jul 23 '15 at 22:24

FYI: I got this error because my password wasn't complicated enough. Host blocked it. New password solved the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.