Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

how are you ?

In my website I want to make the author's page and category(slug of it is country) to be in google reslut ..

like this : http://rehlat-world.com/profile/saqaf , but when I search in google : site:rehlat-world.com , I didn't find authors page.

how can include authors page in google result , this is my robort and this is my sitemap

note: I change the slug of author ( http://rehlat-world.com/author/** from author to profile ( http://rehlat-world.com/profile/** ) ..

how can include author page in google result ?

ALSO , when I search in google (site:rehlat-world.com) some of posts repeated like this :

http://rehlat-world.com/%D8%A7%D9%84%D9%8A%D9%85%D9%86-%D8%A7%D9%84%D8%B3%D8%B9%D9%8A%D8%AF-%D8%AC%D9%88%D9%84%D8%A9-%D8%B3%D9%8A%D8%A7%D8%AD%D9%8A%D8%A9-%D9%85%D8%B5%D9%88%D8%B1%D8%A9-%D8%AC2.html

http://rehlat-world.com/%D8%A7%D9%84%D9%8A%D9%85%D9%86-%D8%A7%D9%84%D8%B3%D8%B9%D9%8A%D8%AF-%D8%AC%D9%88%D9%84%D8%A9-%D8%B3%D9%8A%D8%A7%D8%AD%D9%8A%D8%A9-%D9%85%D8%B5%D9%88%D8%B1%D8%A9-%D8%AC2.html?replytocom=37

same reslut but change in the last of like "?replaytocom=37" WHY?

share|improve this question
1  
The long links that you see repeated are comments. The numbers/percent signs are url encoded forms of the arabic alphabet. the ReplyToCom=x is the comment #. This looks like it has to do with your theme since my theme uses anchor tags instead of a querystring. –  mrtsherman Mar 29 '11 at 14:28
    
I know the long link (arabic link) but ?replaytocom=* how can remove it from google result –  AboSami Mar 29 '11 at 15:19

1 Answer 1

up vote 3 down vote accepted

The problem is that your author pages are marked with the noindex tag, look at the page source:

It must be a plugin that is doing that, that is not the default setting.

If you don't want the duplicate pages, try a plugin like Yoast WordPress SEO that let you add Nofollow to comment links.

share|improve this answer
    
this is the source of author page <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" /> <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> <meta name="robots" content="noindex, follow" /> –  AboSami Mar 29 '11 at 15:11
    
Do you mean this? –  AboSami Mar 29 '11 at 15:12
    
wow thank you very much , I found the problem , I probram new fucntion if is_author echo <meta ..... > .. thank you very mcuh –  AboSami Mar 29 '11 at 16:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.