Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I use a W3Total cache plugin in my WordPress. After I enabled minify (automatic and/or manual), my theme break. It's Javascripts and CSS are not working. In Minify, I use its default settings. I have a Genesis framework with focus theme.

Then I manually put the necessary .htaccess codes by referring W3Total, "Install" guide. My VPS doesn't use any minify mod (like google pagespeed mod), it only use Apache (backend) and Nginx (front-end). However, still I can't fix this issue. So what could be the reason and how do I fix this issue?

After I enabled, minify debug. Now it shows following error.

W3 Total Cache error: It appears Page Cache URL rewriting is not working. Please verify that the server configuration allows .htaccess

Unfortunately disk enhanced page caching will not function without custom rewrite rules. Please ask your server administrator for assistance. Also refer to the install page for the rules for your server. Technical info .htaccess file contains rules to rewrite url http :// www. mydomain. com/w3tc_rewrite_test into http :// www. mydomain . com/?w3tc_rewrite_test which, if handled by plugin, return "OK" message. The plugin made a request to http :// www. mydomain .com/w3tc_rewrite_test but received: 404 Not Found instead of "OK" response.

Note! I can't post more than 2 links, therefore I added a space between www, .com and http

Thanks!

share|improve this question

closed as off-topic by birgire, Johannes Pille, G. M., Wyck, Pieter Goosen Aug 21 at 4:26

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Your question should be specific to WordPress. Generic PHP/JS/HTML/CSS questions might be better asked at Stack Overflow or another appropriate site of the Stack Exchange network. Third party plugins and themes are off topic." – birgire, Johannes Pille, G. M., Wyck, Pieter Goosen
If this question can be reworded to fit the rules in the help center, please edit the question.

    
This is really a VPS and nginx question and not WordPress. –  songdogtech Jan 21 at 15:11
    
My VPS hosting mentioned it's related to Apache. But Apache rewrite work fine. So how do I enable Nginx rewrite? –  Chathu Jan 22 at 3:01

1 Answer 1

That's your answer:

Please verify that the server configuration allows .htaccess

Enable mod_rewrite under nginx on your VPS.

share|improve this answer
    
I ask my VPS hosting company to enable Nginx rewrite. They mentioned W3 rewrite rule work with only Apache (Apache run in backend). Is it true? Could you please tell me how do I enable Nginx rewrite? –  Chathu Jan 22 at 3:00
    
That's a server question and has nothing to do with WordPress; you need to try serverfault.com –  songdogtech Jan 22 at 3:23
    
I forgot to mentioned this one. My htaccess file other rewrite commands are properly working. So I think its not a server side issue. Eg:-<IfModule mod_rewrite.c> RewriteEngine On RewriteCond %{QUERY_STRING} . RewriteCond %{QUERY_STRING} !^(s|p)=.* RewriteCond %{REQUEST_URI} !.*wp-admin.* RewriteRule ^(.*)$ /$1? [R=301,L] </IfModule> –  Chathu Jan 22 at 5:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.