Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Hi all i did the install but now is asking me if i have : * Are you sure you have the correct username and password? YES * Are you sure that you have typed the correct hostname? YES * Are you sure that the database server is running? NOT SURE

how do i know my local server is running when using /phpmyadmin

i will apprciate any help

sincerely

JIm

share|improve this question

migrated from stackoverflow.com Mar 25 '11 at 12:10

This question came from our site for professional and enthusiast programmers.

    
@JIM are you running your local server on Linux ? Mac ? Windows ? Which tool are you using ? EasyPHP ? Wamp ? A custom LAMP stack ? –  Artusamak Mar 8 '11 at 20:50
    
Windos Im using wamp server abd reads: This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost. This could mean your host's database server is down. when the php has the info that should be calling.. i will appreciate your help –  JIM Mar 8 '11 at 20:54
    
Have you created a MySQL database and MySQL user for that database, and entered that information into the wp-config.php file? (additionally have you renamed the wp-config-sample.php to wp-config.php ?).. –  t31os Mar 9 '11 at 13:27
    
got it working! thanks –  JIM Mar 9 '11 at 17:48
    
Your question isn't clear... what is the situation on the local server, and what is the concern with regards to moving to a production server? I assume you've adjusted the permalinks settings in the dashboard, and have allowed it to write to .htaccess by setting its CHMOD to 777 (temporarily)? –  Gavin Mar 9 '11 at 17:55
show 3 more comments

1 Answer 1

You don't rename the links with .htaccess when using Wordpress. Simply go to Settings->Permalinks from your dashboard and select the scheme you want. Going by your sample URL, you could put /%postname%/ in the Custom Structure field to get just the post name.

share|improve this answer
    
HI JohnP i have tried but still does not change i have inserted: /%year%/%monthnum%/%day%/%postname%.htm and does not recognizes the page on my local host only localhost/wordpress/?p=123 –  JIM Mar 9 '11 at 18:29
    
Try selecting month and name from the options without entering anything in the custom field. Also, please not that your permalinks will not change. Only your pretty links. When you move the blog, you need to change the baseurl. This is set in your wp-config.php –  JohnP Mar 9 '11 at 18:34
    
does'nt work this template has a default for the =idpage? and everytime i update the permalinks it overwrites the .htaccess –  JIM Mar 9 '11 at 18:57
    
The permalinks overriding .htaccess is the expected behavior. If the template doesn't use the proper markup, you might have to change it. Normally, moving the blog only requires that you update the base url. I've done it before and it works without a hitch –  JohnP Mar 9 '11 at 19:00
    
the reason i ask , because 1. i'm working on my local host 2.when uploading the files from my local host to overwrite the new template on my website, what's the procedure? –  JIM Mar 9 '11 at 19:23
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.