Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

So I downloaded a plugin that sets your max_file_upload to 250 MB and I set my php.ini to the same. I own server so it is not a server issue - I have many apps that upload very large video files.

When I am trying to upload a file, no matter how large (up to 200MB tested), it shows that the file uploads in the progress bar. If it were going over the upload limit I get an error telling me file is too big - but this is not the case.

Instead a second or two after hitting 100% on progress bar it times out with "http error". Seems like a memory issue with WP so I added define('WP_MEMORY_LIMIT', '250MB');

Doesn't work. Let me know what else I can do. It is not an issue with server. When I do phpinfo it shows 250M and I have upload many files larger than 8M on other apps on same server.

Name of the plugin is PBP Increase upload limit. Also when I do not have the plugin on I cannot download big files at all. With the plugin I can download the file - but when it gets to the "crunching" progression it faults out with the http error.

share|improve this question
2  
What is the plugin you are using? Have you tried that plugin's support forum? –  Dan Jan 13 at 21:49

1 Answer 1

In your php.ini make sure you're changing both of the following lines.

upload_max_filesize = 250M
post_max_size = 250M

If you are using FastCGI as your PHP engine you'll also need to up its limit in Apache. Try adding FcgidMaxRequestLen to your VirtualHost (see http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html#fcgidmaxrequestlen for more info on the directive).

Finally, if you're on NGINX you might need to set

client_max_body_size 20M;

You'll do this under the http section of nginx.conf (see http://wiki.nginx.org/HttpCoreModule#client_max_body_size for more information)

share|improve this answer
    
Chris - I have tried the php.ini file several times and it never works. I am on W2008 so don't know if that makes a difference. The plugin allows the initial download to start but it doesn't complete. –  STing Jan 16 at 15:32
    
Are you using IIS or another web server? –  Chris Wiegman Jan 17 at 15:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.