Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am setting up a local development environment for a WordPress site on a Ubuntu desktop. When I go to run the installer at nimble-demo.local/wp-admin/install.php, the page loads but every script and stylesheet returns a 404 Not Found.

I don't think it's a permissions issue because wp-admin/install.php, which loads, and wp-admin/css/install.min.css, which does not load, have the same permissions: 755, owned by dan:dan (me). The project is located inside my home directory, and my virtualhost is configured accordingly:

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName nimble-demo.local
    SetEnv DATABASE_URL postgres://nimble_demo:xxxxxxxx@localhost:5432/nimble_demo

    DocumentRoot /home/dan/WMM/demos/nimble-demo/
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /home/dan/WMM/demos/nimble-demo/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride all
        Order allow,deny
        allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    ErrorLog /home/dan/WMM/demos/nimble-demo/error.log

    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn

    CustomLog /home/dan/WMM/demos/nimble-demo/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>

I am able to serve a simple html file that links to a stylesheet from another virtualhost in my home directory with a nearly identical setup, so I am thinking that the problem I am having is probably WordPress related.

share|improve this question
    
If the links are correct then WP is not the issue, it does not interfere with serving static files (even if they are coming from its folders). –  Rarst Jan 10 at 13:06
    
Whoops, the links are all to the 127.0.0.1 domain, not to the nimble-demo.local domain I set up in my hosts file. Thanks for pointing that out. –  Dan Ross Jan 10 at 18:26
    
What are WP/site URLs in Settings > General ? –  Rarst Jan 10 at 18:34
    
I haven't installed yet, I'm going to change the site url in wp_config. I'll set using the dashboard after the install completes. –  Dan Ross Jan 10 at 18:48
    
Defining WP_HOME and WP_SITEURL in wp-config.php doesn't have any effect. WordPress is still using 127.0.0.1. –  Dan Ross Jan 10 at 18:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.