Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have tried everything I've found.

I can't stop webhostingbreak.com/ipage/ from redirecting to webhostingbreak.com/hosting-directory/ipage-hosting/

I tried remove_filter('template_redirect', 'redirect_canonical'); in my theme's functions.php.

I tried removing or commenting out add_action(‘template_redirect’, ‘redirect_canonical’); in /wp-includes/canonical.php

I even removed EVERY line of code in canonical.php and still no result... It still redirects like I've done nothing.

I changed webhostingbreak.com/hosting-directory/ipage-hosting/ to webhostingbreak.com/hosting-directory/test/ and then I cleared the database of any attachements/old slugs that might cause redirect. It STILL redirects.

I'm out of ideas. I've spend 20 hours trying to find answers on this.

share|improve this question
    
What plugins do you have activated? –  MikeSchinkel Mar 24 '11 at 8:02
    
Yoast Wordpress SEO, Akismet, Advanced Excerpt, FB Open Graph, MyReviewPlugin, Revision Control, W3 Total Cache, WP No Category Base –  user4169 Mar 24 '11 at 8:18
    
could have something to do with WP No Category Base , deactivate it and resave the permalink settings. –  Bainternet Mar 24 '11 at 9:33
    
You can intercept and debug the redirect, if it is executed via the standard WordPress wp_redirect() function. –  Jan Fabry Mar 24 '11 at 18:12

1 Answer 1

If that is just one exception you could add an .htaccess rule for it or just use the Redirection plugin. It's not the best solution but neither is spending 20 hours on it.

Btw, Yoast WordPress SEO has the ability to remove the category base, you don't need the second plugin anyway.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.