Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm having an issue with a third party plugin called WP-Calendar, where clicking on the "next" and "prev" links in a small calendar results in a redirect error.

This problem only appears to be happening on archive pages, as I have the calendar on the front page of a few MU pages and it does not have the same problem.

Clicking the links basically adds the following to the URL:

?month=may&yr=2011

Which changes depending on the current month viewed. This leads me to believe that there's something up with the archive / category page accepting parameters through $_GET. To test this theory I tried ?a=b at the end, and I still got the same redirect error (The page isn't redirecting properly).

Anyone know why the archive pages won't accept inputs through the URL?

EDIT: Some additional information that I should've mentioned, I've tested all of the plugins and the problem still exists after disabling them. The theme being used is a style modified version of this: http://www.woothemes.com/2008/02/gazette/. Also the permalink settings are custom to: /%category%/%postname% and category base is . to get an URL such as myurl.com/category to work for a category landing page.

share|improve this question
    
A few questions to get a better understanding: what does your permalink setting look like (under Settings -> Permalinks)? Are you running many other plugins on this site? Is it possible to disable them all except for the calendar and see if it works then? There are a lot of plugins which are "grabby" when it comes to GET/POST data, and it's sometimes a bit hard to know what's going on without running the plugin you're having issues with by itself. –  Gavin Anderegg Mar 23 '11 at 23:12
    
Sorry I should've mentioned, I've tested all of the plugins and the problem still exists after disabling them. The theme being used is a style modified version of this: woothemes.com/2008/02/gazette. Also the permalink settings are custom to: /%category%/%postname% and category base is . to get an URL such as myurl.com/category to work for a category landing page. –  Dave Hunt Mar 23 '11 at 23:36
1  
Sorry, you say your category base is .? As in, the "Category base" field just contains the . character? I tested this and it didn't work at all for me. It looks like Apache got sent into an infinite redirect loop. –  Gavin Anderegg Mar 24 '11 at 12:24
    
That was the problem, thanks Gavin! If you want to create an "answer" I'll mark it as correct. –  Dave Hunt Mar 28 '11 at 4:13
    
Thanks! –  Gavin Anderegg Mar 28 '11 at 12:27
add comment

1 Answer

up vote 1 down vote accepted

As per the discussion in the comments, using . as a value for the "Category base" will send Apache into an infinite loop. Getting rid of the Category base in the URL is actually pretty tricky, just because of the way WordPress expects things to work. It you want to use a single character for this, though, the _ character works just fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.