Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm finding this string appended to the end of my URLs sometimes:

/?doing_wp_cron

Does anyone know what it for? How can I remove it?

share|improve this question
    
This is happening with the plugin All In One Event Calendar. Solution in its case is to define ALTERNATE_WP_CRON as false in wp-config.php. –  brasofilo Oct 6 '12 at 17:02
add comment

4 Answers

up vote 6 down vote accepted

It's a sign that you have ALTERNATE_WP_CRON defined in your wp-config.php

In order to do some background processing (like publishing scheduled posts), WordPress redirects you to the URL with ?doing_wp_cron appended.

share|improve this answer
    
Thanks! Do you know what I could do to get rid of that from the end of my URLs? –  Andrew Warner Mar 24 '11 at 13:35
    
Remove the line from wp-config.php (although that might stop cron from working). –  scribu Mar 24 '11 at 13:38
    
@scribu iThemes suggests to set up that line in the wp-config file to get BackupBuddy to work, thus removing that line again makes sure that the plugin no longer works. To your knowledge is there another "solution" to this other than dumping BackupBuddy? –  Piet Sep 15 '11 at 14:49
    
@Piet: That's a rather strange requirement on the part of iThemes. A possible solution would be using UNIX cron jobs. Open a new question. –  scribu Sep 15 '11 at 21:54
    
@scribu thanks for your suggestion, new question is posted: wordpress.stackexchange.com/questions/28718/… –  Piet Sep 16 '11 at 15:03
add comment

I have seen many posts about this problem but few of them succeed to found a real solution. What solves this problem for me has been to manage redirection in the .htaccess file.

Here is an exemple on how to redirect the url by adding these lines in the .htaccess file :

<IfModule mod_rewrite.c>
    Options +FollowSymLinks
    RewriteEngine On
    RewriteCond %{QUERY_STRING} (^|&)doing_wp_cron= [NC]
    RewriteRule (.*) /$1? [R=301,L]
</IfModule>

Hope this will help !

Note : this tips comes from this forum

share|improve this answer
1  
That’s not ideal. It would be better to disable the alternative cron. –  toscho Oct 26 '12 at 14:56
    
@toscho : Here is what I have understood (maybe i am missing something). the 'ALTERNATE_WP_CRON' param disables cron job from Wordpress point of view. So it is disabled in the Wordpress "engine". Then the 'All in one Event Calendar' plugin, BackWPup, and all stuffes that need job schedules wont be able to proceed their jobs. By playing with the Apache redirection, the Wordpress engine wont be affected. That's what I figure out but not everything is clear to me. Where am I wrong ? –  Gepeto Oct 26 '12 at 21:39
add comment

@scribu I believe that BackupBuddy uses WordPress task scheduling to schedule tasks as a part of the backup procedures - if the site has loopbacks disabled then the only solution (apart from some bespoke external solution) and the specific alternate solution that, as I am sure you know, is integrated into WordPress, is the alternate cron fix. So this is only "required" if the host has loopbacks disabled. Bear in mind that if that is the case then no scheduled tasks, be they standard WordPress scheduled tasks or those associated with other plugins, will work. What seems to be the case is that a user will not know that their host has hobbled their WordPress installation until they try BackupBuddy because that makes the problem obvious rather than it having been invisible until that point.

Using crontab type approach is only a sticking-plaster because, unless you make it "ping" the WordPress cron processing very frequently that will only work with some types of scheduled tasks.

Of course if a user doesn't want to or cannot use the alternate wp cron fix, doesn't want to move to a host that does allow loopbacks and isn't knowledgable enough to be able to set up a suitable crontab based capability then BackupBuddy does offer a manual backup mode that will work but it lacks the flexibility ana some of the capabilities of that available when scheduling is available.

share|improve this answer
add comment

What causes this issue is alternate cron. To workaround this, if you have access, you can enable an actual cron process (if your hosting will let you) and disable ALTERNATE_WP_CRON in your wp-config.php.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.