Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Hello I am having a problem in a pre tag.

All of a sudden all my '->' appear as '-&gt ;' on my blog. How can I solve this? I have updated to the newest version.

share|improve this question

1 Answer 1

If you've written it as it actually appears, you are missing the semi-colon ; directly following the &gt. Sometimes moving between the visual editor and the html editor will cause this problem. It can also happen when copying and pasting code from another source. Go into the HTML editor and check the code where the greater than signs should appear to ensure that the semi-colon follows the &gt.

Hope this helps

share|improve this answer
    
Thanks for your reply. The semicolon was a mistake in copy/pasting. But it happens indeed when switching between the code and the visual editor. Is there a fix for this problem? –  sanders Mar 23 '11 at 7:49
    
@sanders - I don't think it's considered a bug or problem. It is definitely an annoyance. The intention of the visual editor is to give you a representation what the page will look like when displayed, so it uses visual elements. In most cases for a blog, no problem. With code, it causes havoc. Like the old wise ones would say, "Forewarned is forearmed". –  Ray Mitchell Mar 23 '11 at 12:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.