Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm working on a particularly large WordPress multisite network, and have been struggling with WP-Cron. It seems that WP-Cron tasks are being scheduled, but not run.

The WP-Cron tasks are not being run on either our staging or production environments, but locally, they run fine. The instances are all identical—multisite, with the same set of sites, the same theme, and the same plugins activated (and same versions of plugins). There are slight differences in the version of PHP on the server and in my local sandbox, but the WP versions are the same (a little behind the current – 3.5.2)

I've tried clearing the queue, and hitting the cron script directly (/wp-cron.php?doing_wp_cron), but without success. I even tried scheduling a call to that script in an actual cronjob, but with the same result—nothing.

I double-checked that DISABLE_WP_CRON is not present in the wp-config file, and even played with defining that constant to false.

Any insight into why it might not be running, or how to force it to run, would be very helpful.

share|improve this question
    
Do you have access to the server logs on your staging and production boxes? See if there are any errors in there related to wp_cron.php. –  Pat J Dec 24 '13 at 2:09
    
If you're using a direct call to the script via cron and it's not working, then my guess is it's not a wordpress issue, so I'd start by checking the script itself and it's file permissions. –  TomC Dec 24 '13 at 8:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.