Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I had to delete all my files of web site for some reasons.

Then I've restored the files back to host.

But the problem is that;

Firstly, I uploaded all the images (about 4000) to upload folder via FTP. Then I realised that images are not showing up in media library. Than I used some plugins such as, Add from Server, Media Tools, but they coludnt operate all the files. I dont know why.

Then I deleted all the files again and uploaded via Wordpress Library -> Add new. After uploading all images they showed up in media library BUT they are not attached to "Uploaded to this post" of posts.

If anyone knows the solution, could you please help me about this.

Thanks.

share|improve this question
add comment

1 Answer

When you upload an image within the post edit screen, the image gets the parent id that of the post id you are editing. In this case if you check the Media Library screen, you will see the post mentioned under Uploaded To column against that image.

On the other hand if you directly upload an image from Media Library screen, then there will be no post mentioned against that image. Rather you will see Unattached under Uploaded To column for that image.

You can use the Attach link against that image and select the post you want to attach that image to. After that if you check in the edit post screen, you will see the image on selecting Uploaded to this post option.

share|improve this answer
    
Since you have a lot of images, Attachments plugin may be helpful to you but I have never tried this. –  Chittaranjan Dec 13 '13 at 10:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.