Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I installed a fresh copy of Wordpress 3.7.1 last week and uploaded an image using the media uploader. The image was uploaded alright, I could see it with FTP, but requesting it returned an HTTP error 404. WP had set the permissions of the directories uploads, 2013 and 11 to 0754. So I set them to 0755, and everything was fine.

Now it's December so WP had to create the 12 directory. It again choose to set it to 0754.

Any ideas on what might be wrong? Isn't it supposed to use the parent directory's permissions? And what I can do to fix this? FYI, wp-contents has 0755.

Edit: Files and folders are owned by the user the web server runs as, and group ownership seems OK too. I've now also tried setting directory permissions for wp-content, uploads and 2013 to 0775. Uploaded an image: the 12 directory got 0754 again.

Edit 2: OK, I guess I'll have to get in touch with my provider. It's a cheap hosting account, no shell access, certainly no access to the web server config.

share|improve this question
    
    
I've edited/updated my question. –  RonaldPK Dec 5 '13 at 18:26
1  
WordPress doesn't set permissions, your server does. –  Milo Dec 5 '13 at 18:34

1 Answer 1

Isn't it supposed to use the parent directory's permissions?

No, according to this file permissions n creation are set by apache. You will need to look at your apache config and OS settings to find the reason and fix it.

It it might be that your umask parameter is 003 instead of 002.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.