Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When I upload image, I can preview it, but once it's uploaded, It's broken in post, I'm obliged to go to the directory and go to security to add NETWORK SERVICES the right to access the picture.

How to fix this ? Is this a bug ?

share|improve this question

2 Answers 2

You are encountering an improperly configured server. Please consult the Wordpress manual on how to setup wordpress on a windows server system.

AFAIK - but I'm not a windows server expert - you must configure the upload directory that the user executing the PHP Wordpress application is able to access files therein for reading, writing, creating and deleting.

Normally it's possible to configure the needed rights on the parent directory and the same rights will be distributed to the files created therein.

Additionally you can consider to run Worpdress on a *nix based host, that's for which it has been written for and which it bests supports.

If you have problems getting it to run and you don't want to switch to linux for your host, you should consider making use of the Microsoft Port of Wordpress.

If you have general questions how to configure a server, please think about asking your question at Server Fault.

share|improve this answer

It wasn't a problem of IIS Server it was a Wordpress Bug. By upgrading Wordpress it didn't happen again.

share|improve this answer
    
Hi, I am having the same issue without luck. Just installed a fresh WP 3.3 with a fresh DB. Any idea what could have caused this? –  Kave Dec 23 '11 at 9:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.