Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've been struggling with this problem and I hope I posted this question in the correct place.

I have a Wordpress site I installed on a dreamhost host, it's a Linux host. I cloned this site over from another host where it works OK. Now, the /wp-admin side works perfectly, I can navigate around and save settings and the like, but when I go to the front side, all I get is a blank page.

When I look at the logs, error_log doesn't get anything, but access_log gets this line:

123.456.789.012 - - [19/Nov/2013:21:07:34 -0800] "GET / HTTP/1.1" 304 186 "-" "..."

Of course the IP is not the one it shows and the "..." part is just the browser information.

My Linux box is... well, I have never seen this before, but when I run uname -a it returns this:

Linux boxwood 3.2.45-grsec-2.9.1-r3+ #63 SMP Fri May 24 02:11:07 UTC 2013 x86_64 GNU/Linux

Anyway, I'm also able to go directly to any other page in the site, or at least all the pages I have tried, it looks like this only affects the homepage.

Does anybody have ever had an issue like this? If so, can you please share how you fixed it?

Or anyone who can help me out troubleshoot this, because I ran out of ideas. Don't know if the GET codes I get are the answer, because I looked up the 304 here and it's just not clear what I need to do, it mentions something about the document not being modified, but I can't figure out what to do to fix it.

What I have already done:

  1. Used a different .htaccess file - or no .htaccess file at all, and no luck.
  2. I enabled WP debug mode, page still blanks out.
  3. Reset many settings in Wordpress that I thought might be causing this - still no luck.
  4. Googled the 304 response code but didn't understand what to do next :S

Thank you guys

share|improve this question

migrated from serverfault.com Nov 20 '13 at 9:27

This question came from our site for system and network administrators.

1 Answer 1

up vote 0 down vote accepted

Stupid me... the root folder had an empty default.html file and that's what it was rendering... removed teh file and it works now

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.