Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've installed WP 3.7.1 on Apache (Linux). Note that this is a brand new install.

I configured it for Network Sites (Sub folders). When I go to the root site (i.e. http://example.com/) I see the blog. When I go to a new site that i created in the main dashboard (http://example.com/newsite/) I get a 404 error message.

I've searched a lot of articles but have been unable to resolve the issue. Here's my .htaccess file:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

My wp-config.php file looks like this (just at the bottom, these are all the changes I've made):

/* Multisite */
define( 'WP_ALLOW_MULTISITE', true );

define('MULTISITE', true);
define('SUBDOMAIN_INSTALL', false);
define('DOMAIN_CURRENT_SITE', 'aggrssgator.com');
define('PATH_CURRENT_SITE', '/');
define('SITE_ID_CURRENT_SITE', 1);
define('BLOG_ID_CURRENT_SITE', 1);

Update: I've solved the issue (see my comment below - wasn't allowed to answer my own question)

share|improve this question
    
what kind of 404 page do you get, from your hosting or from wordpress? are you able to get to the admin of "newsite"? –  Mark Kaplun Nov 14 '13 at 6:23
    
Most of those defines should not be in the multisite install. Defining the various CURRENT_SITE settings will effectively disable multisite by forcing it to the main site. None of that other than the first line should be in your wp-config file. And there should definitely not be any settings "at the bottom" of the file. I think you may have setup your config incorrectly to start with here. –  Otto Nov 14 '13 at 6:27
    
Just found this article: zefur.wordpress.com/2010/06/30/… Solution: Modify httpd.conf > search for AllowOverride None and change to AllowOverride All They're multiple AllowOverride settings in the conf file. I just modified the main one (under <Directory "/var/www/html"> ). Once the change was in place I restarted the httpd service and it worked. –  Martin Giffy D'Souza Nov 14 '13 at 6:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.