Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm a relatively new Wordpress user, usually I just code my sites by hand though I'm trying to move to a CMS. I installed Wordpress onto a subforlder (http://www.iss.guild.uwa.edu.au/wordpress/) to test. Every now and again I would get warning messages like below, though starting today I started getting fatal errors. According to my server admin he has PHP 5.2.6 and MySQL 4.1.2 installed. Also it doesn't seem to help on whether I'm using Wordpress 3.1 or Wordpress 2.7 (which had been installed by someone else some time back and seemed to work) Fatal error screenshot Warning screenshot

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

The Health Check plugin is triggering the first error. Is this when you're running 2.7? get_transient() was only introduced in 2.8, which would explain it's absence.

The second failure is merely a failed HTTP request. This can happen every now and then (mainly due to timeouts). It shouldn't interrupt the normal functioning of WordPress (the HTTP request was made by wp-cron.php, which is triggered as a separate request).

The obvious advice is;

  • Upgrade to 3.1 if you're not running it, now!
  • Update any active plugins
  • Ensure you are using a fairly regularly maintained theme (or if you built it yourself, make sure you're using best practices and have removed calls to any deprecated functions).
share|improve this answer
    
Yes I was running 2.7 cause I've been told by my predecessor that the new Wordpress is not compatible with the server, though it seems like the PHP and MySQL version has been upgraded. For the second failure, is it considered normal for it to happen every 7/10 times? I use Wordpress for my own website but I have never actually seen this warning before. –  jon2512chua Mar 17 '11 at 8:20
    
No, shouldn't be that often. Upgrading may well fix the issue. Your set-up seems perfectly adequate for 3.1 (which still supports PHP 4.3). –  TheDeadMedic Mar 17 '11 at 8:42
    
The 7/10 times was when I was using 3.1 actually. Just reverted back to 3.1 and we'll see how it goes. Thanks. –  jon2512chua Mar 17 '11 at 9:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.