Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm facing a hell of a problem on a client's WP theme. Whenever I try to 'Activate' it, it gives me the following errors on a blank page:

Warning: include(/homepages/32/d207857955/htdocs/wp-content/themes/kvinterior/functions.php): failed to open stream: Permission denied in /homepages/32/d207857955/htdocs/wp-settings.php on line 316

Warning: include(): Failed opening '/homepages/32/d207857955/htdocs/wp-content/themes/kvinterior/functions.php' for inclusion (include_path='.:/usr/lib/php6') in /homepages/32/d207857955/htdocs/wp-settings.php on line 316

Warning: include(/homepages/32/d207857955/htdocs/wp-content/themes/kvinterior/home.php): failed to open stream: Permission denied in /homepages/32/d207857955/htdocs/wp-includes/template-loader.php on line 74

Warning: include(): Failed opening '/homepages/32/d207857955/htdocs/wp-content/themes/kvinterior/home.php' for inclusion (include_path='.:/usr/lib/php6') in /homepages/32/d207857955/htdocs/wp-includes/template-loader.php on line 74

I think, the wp-config is changing the file permissions automatically which causes the problem. The hosting provider tells me that these four files are malware infected. If either or even if neither of the two cases prevail, please provide me a solution.

P.S. - All the other themes work perfectly fine.

share|improve this question
    
why did you bother to attach an image if it is not readable? please remove it, improve it, or just copy the file name into the question. –  Mark Kaplun Nov 8 '13 at 7:17
    
I'm sorry I didn't realize it until now, I've simply added the errors here now. Thanks for the heads up Mark –  Nimsrules Nov 8 '13 at 7:24
    
have you checked if the files actually exist at those locations, and do they have a read permission? –  Mark Kaplun Nov 8 '13 at 7:36
    
I change the permissions of all the files to 'read & write' before uploading, still the above problem persists. –  Nimsrules Nov 8 '13 at 8:36
    
are the files (funcrtion.php etc) in that specific location? –  Mark Kaplun Nov 8 '13 at 8:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.