WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Somehow, it doesn't seem to be possible to plan post for my subscibers (visibility private) as they get published private automatically as soon as I save them.

Is there any way I can keep wordpress from doing so?

share|improve this question
Deactivate all plugins, switch to the default theme. Does it still happen? – kaiser Nov 5 '13 at 0:36
thanks for your suggestion, unfortunately, this did not do the trick :( – nozzleman Nov 5 '13 at 8:12
up vote 3 down vote accepted

The problem is that changing the post visibility to private invokes a status change, in a way private is not only a visibility but also a publishing status. Or to quote the Wordpress Codex, section »Content Visibility - Private Content«.

Once you change the visibility to private, the post or page status changes to "Privately Published" as shown. Private posts are automatically published (...).

To achieve what you want you probably have to work with the publish_post or even better the publish_future_post hook. Another possibility is to work with Post Status Transitions and the according hooks.

share|improve this answer
Thanks, that seems to answer my question. So as far as I understand, I might have to code? I was hoping there as an easier way ;) – nozzleman Nov 5 '13 at 8:16
Not that I know of, but if you find one, come back an d share it. I recently wrote an answer about making a custom post type private by default, of course this isn't exactly what your are looking for, but maybe it'll help you out getting there anyway. – ialocin Nov 5 '13 at 14:01
If i find a Solution of course. – nozzleman Nov 5 '13 at 15:08

Have you checked your timezone settings under Settings -> General? One of the things that can cause this is if the schedule date is in the past according to the configured timezone but not according to your time.

share|improve this answer
Are you really, really sure about that? – kaiser Nov 5 '13 at 13:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.