Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm using this library to auto-update my plugin, but it's only extracting the new plugin files into a .tmp directory, while the old plugin files stay where they are. Can anybody help me fix this to overwrite the old files or any ideas as to why it would be doing that?

Edit: I know that the library above does not actually install the update, but the WP core updater does, so it has something to do with that. Any ideas?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Are you able to update standard WP repo plugins? I am using that library and it seems to work well.

What's the exact error that WordPress gives on the admin screen when it tries to run the update?

I would take a look at permissions first. What are the permissions on the old plugin directory? Any different than any of your other plugin directories?

I would also take a look at the format of the zip file you're feeding it. What software did you use to create the zip? When you unzip it, what does the directory structure look like? It should unzip as a folder with the same name as the plugin you're trying to replace. Did you set the slug attribute in the JSON file? Does that also match the folder name?

Hope this helps. I was able to get that library going pretty quickly.

share|improve this answer
    
with your suggestion, I was able to figure out my problem. Thank you much! :) –  Jared Mar 15 '11 at 10:50
    
@Dalton, the solution in my case was this: "It should unzip as a folder with the same name as the plugin you're trying to replace" –  KalenGi Mar 5 '12 at 11:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.