Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm trying to archive my tweets in Wordpress and display recent ones in my sidebar. I've installed the Twitter Tools plugin, configured it, and added its widget to my sidebar. Twitter Tools is creating blog posts for each of my tweets, so I know it is authorized by Twitter successully. However, the sidebar widget just displays "No tweets available at the moment."

I've tried the procedure described here to uninstall and reinstall Twitter Tools to no avail.

I'm also using the Ultimate Category Excluder plugin to exclude the tweet posts from my feed and homepage. I'm worried that might be the problem but others seem to be using this setup successfully. Any ideas?

share|improve this question
add comment

3 Answers

@Ben, It could be a problem with Twitter's new Oauth rules that went into effect on August 31st. Alex updated the plugin to work with Oauth but I am hearing a lot of people are having problems with it.

Are you running the latest version of the plugin? Have you set up your Twitter app and api key?

Also to note that php5 is required.

share|improve this answer
    
I'm running Wordpress 3.0.1, Twitter Tools 2.4, PHP 5.2.4. I did the Twitter app and api key, and I think that is working since Twitter Tools creates blog posts from my tweets. –  Ben Williams Sep 2 '10 at 15:12
add comment
up vote 1 down vote accepted

I kept digging on this and I found that the Twitter Tools widget depends on a table called wp_ak_twitter. I didn't have this table, probably because my Wordpress database user doesn't have create table privileges. I create the table by hand and now the widget is working.

share|improve this answer
add comment

I would suggest a problem with your excluder setup. As you say the fact that the blog posts are being created demonstrates the successful connection to twitter.

I would disable the excluder plugin and force it to manually update on the twitter tools settings page. If your tweets show then I would re-enable the plugin and work within its settings to correct the problem.

MM/RC

share|improve this answer
    
Good suggestion but deactivating Ultimate Category Excluder made no difference. –  Ben Williams Sep 2 '10 at 15:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.