Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

i'm embedding a wordpress blog in a html page and i did the steps to successfully add the header and the footer of my site www.srougi.biz/soulfighter/blog. But now I need to stylize my single.php that is the page that shows the full post when user clicks in the post title. I've added the commands below that should bring the customized header and footer, since I stylized header.php and footer.php. But it comes totally unconfigured and doesn't get the style. Can someone please help me? Thanks a lot.

See my single.php code:

<?php
global $OLDCAR_VAN;
get_header();
?>
           <!-- ************************* BLOG ARTICLES ************************* -->
                                    <div class="single-post-page grid-12">
                            <?php while (have_posts()) : the_post(); ?>
                                                            <!-- SINGLE BLOG ARTICLE -->
                                                            <article id="post-<?php the_ID();?>" <?php post_class("single-blog-article");?>>
                                                                    <!-- BLOG ARTICLE HEADER -->
                                                                    <div class="blog-article-header media">
                                                                            <div class="<?php echo format_icon();?>"></div>
                                                                            <div class="bd">
                                                                                    <h1 class="blog-article-title"><a href="<?php the_permalink();?>" title="<?php echo esc_attr(get_the_title());?>" rel="bookmark"><?php the_title();?></a></h1>
                                                                                    <?php echo van_posted_on();?>
                                                                            </div>
                                                                    </div>
                                                                    <!-- BLOG ARTICLE CONTENT -->
                                                                    <div class="blog-article-content rich-content">
                                                                            <?php van_format_content();?>
                                    <?php wp_link_pages('before=<div class="van-pagenavi">&after=</div>');?>
                                    <div class="clearfix"></div>
                                                                    </div>

                                <div class="taglist">
                                <?php the_tags('<strong>'.__('Tags','OldCar').':</strong> ', '' , ''); ?>
                                </div>

                                <div class="pagination">
                                    <span class="nav-previous alignleft"><?php previous_post_link( '%link', __( '&larr; Previous Post', 'OldCar' ) ); ?></span>
                                    <span class="nav-next alignright"><?php next_post_link( '%link', __( 'Next Post &rarr;', 'OldCar' ) ); ?></span>
                                    <div class="clearfix"></div>
                                </div>
</article>
                                                            <?php endwhile;?>

                                                            <!-- COMMENTS  -->
                            <?php comments_template(); ?>
                                    </div><!-- END GRID-12 -->
        </div><!-- END CONTAINER -->
<?php get_footer();?>
share|improve this question
    
What's actually the problem here? Are the stylesheets not being linked? Are styles not being applied? What are you expecting to happen, that isn't happening, or is happening unexpectedly? –  Chip Bennett Oct 14 '13 at 15:18

1 Answer 1

up vote 0 down vote accepted

The problem seems to be the way you are calling these style sheets:

<!-- Libs CSS -->
<link rel="stylesheet" href="../css/bootstrap.css">
<link rel="stylesheet" href="../vendor/flexslider/flexslider.css" media="screen" />
<link rel="stylesheet" href="../vendor/fancybox/jquery.fancybox.css" media="screen" />

<!-- Theme CSS -->
<link rel="stylesheet" href="../css/theme.css">
<link rel="stylesheet" href="../css/theme-elements.css">

<!-- Current Page Styles -->
<link rel="stylesheet" href="../vendor/revolution-slider/css/settings.css" media="screen" />
<link rel="stylesheet" href="../vendor/revolution-slider/css/captions.css" media="screen" />
<link rel="stylesheet" href="../vendor/circle-flip-slideshow/css/component.css" media="screen" />

<!-- Custom CSS -->
<link rel="stylesheet" href="../css/custom.css">

<!-- Skin -->
<link rel="stylesheet" href="../css/skins/skin.css">

<!-- Responsive CSS -->
<link rel="stylesheet" href="../css/bootstrap-responsive.css" />
<link rel="stylesheet" href="../css/theme-responsive.css" />

<!-- Favicons -->
<link rel="shortcut icon" href="../img/favicon.ico">

<!-- Head Libs -->
<script src="../vendor/modernizr.js"></script>

From the home page, ../ adds http://www.srougi.biz/soulfighter/ to each style sheet path.

In this single.php page, ../ adds http://www.srougi.biz/soulfighter/blog/2013/10/10/ to the style sheet path. Since the style sheets are not in that directory, they do not load.

You didn't show the code used to produce these <link>s, but I'll bet you didn't enqueue them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.